summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-09 21:30:46 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-09 23:55:47 +0100
commit29096ed296fc06a8085e244530b72329a897d1e3 (patch)
tree48368d3286c7a00bf1ce66148ed148be261a5e09 /dev-lua
parentdev-lua/luaexpat: drop 1.3.0-r103 (diff)
downloadgentoo-29096ed296fc06a8085e244530b72329a897d1e3.tar.gz
gentoo-29096ed296fc06a8085e244530b72329a897d1e3.tar.bz2
gentoo-29096ed296fc06a8085e244530b72329a897d1e3.zip
dev-lua/luafilesystem: update EAPI 7 -> 8
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/luafilesystem/luafilesystem-1.8.0-r1.ebuild82
1 files changed, 82 insertions, 0 deletions
diff --git a/dev-lua/luafilesystem/luafilesystem-1.8.0-r1.ebuild b/dev-lua/luafilesystem/luafilesystem-1.8.0-r1.ebuild
new file mode 100644
index 000000000000..a9140fcba06d
--- /dev/null
+++ b/dev-lua/luafilesystem/luafilesystem-1.8.0-r1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit lua toolchain-funcs
+
+MY_PV=${PV//./_}
+
+DESCRIPTION="File System Library for the Lua programming language"
+HOMEPAGE="https://keplerproject.github.io/luafilesystem/"
+SRC_URI="https://github.com/keplerproject/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv sparc x86"
+IUSE="test"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+RDEPEND="${LUA_DEPS}"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ test? ( ${RDEPEND} )
+"
+
+HTML_DOCS=( "doc/us/." )
+
+lua_src_prepare() {
+ pushd "${BUILD_DIR}" || die
+ cat > "config-${ELUA}" <<-EOF
+ CC=$(tc-getCC)
+ DESTDIR=${ED}
+ CFLAGS=${CFLAGS} $(lua_get_CFLAGS) -fPIC
+ LIB_OPTION=${LDFLAGS} -shared
+ LUA_LIBDIR=$(lua_get_cmod_dir)
+ EOF
+ popd
+}
+
+src_prepare() {
+ default
+
+ lua_copy_sources
+ lua_foreach_impl lua_src_prepare
+}
+
+lua_src_compile() {
+ pushd "${BUILD_DIR}" || die
+ emake CONFIG="config-${ELUA}"
+ popd
+}
+
+src_compile() {
+ lua_foreach_impl lua_src_compile
+}
+
+lua_src_test() {
+ pushd "${BUILD_DIR}" || die
+ LUA_CPATH="${BUILD_DIR}/src/?.so" ${ELUA} tests/test.lua || die
+ popd
+}
+
+src_test() {
+ lua_foreach_impl lua_src_test
+}
+
+lua_src_install() {
+ pushd "${BUILD_DIR}" || die
+ emake CONFIG="config-${ELUA}" install
+ popd
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+
+ einstalldocs
+}