summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-10-13 16:00:04 +0200
committerMarek Szuba <marecki@gentoo.org>2020-10-13 18:47:34 +0200
commit3af402bb34f314334ec7496a9fec777e197b7b99 (patch)
treeed8bd0c34d80c54ab92884980dfa5ffe88862008 /dev-lua
parentdev-lua/messagepack: migrate to lua.eclass (diff)
downloadgentoo-3af402bb34f314334ec7496a9fec777e197b7b99.tar.gz
gentoo-3af402bb34f314334ec7496a9fec777e197b7b99.tar.bz2
gentoo-3af402bb34f314334ec7496a9fec777e197b7b99.zip
dev-lua/toluapp: migrate to lua-single.eclass
Does not support Lua versions newer than 5.1 so didn't even bother adapting this to multi-impl. Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/toluapp/files/toluapp-1.0.93_p20190513-lua-version.patch11
-rw-r--r--dev-lua/toluapp/toluapp-1.0.93_p20190513-r100.ebuild40
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-lua/toluapp/files/toluapp-1.0.93_p20190513-lua-version.patch b/dev-lua/toluapp/files/toluapp-1.0.93_p20190513-lua-version.patch
new file mode 100644
index 000000000000..fda6c253c2e6
--- /dev/null
+++ b/dev-lua/toluapp/files/toluapp-1.0.93_p20190513-lua-version.patch
@@ -0,0 +1,11 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -8,7 +8,7 @@
+ cmake_minimum_required ( VERSION 2.8 )
+ include ( cmake/dist.cmake )
+
+-find_package ( Lua REQUIRED )
++find_package ( Lua ${LUA_VERSION} EXACT REQUIRED )
+ include_directories ( include src/lib ${LUA_INCLUDE_DIR} )
+
+ # Build lib
diff --git a/dev-lua/toluapp/toluapp-1.0.93_p20190513-r100.ebuild b/dev-lua/toluapp/toluapp-1.0.93_p20190513-r100.ebuild
new file mode 100644
index 000000000000..ab25d1fac8dc
--- /dev/null
+++ b/dev-lua/toluapp/toluapp-1.0.93_p20190513-r100.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# Newer Lua versions are NOT supported, see Bug #508222
+LUA_COMPAT=( lua5-1 )
+
+inherit cmake lua-single
+
+MY_PN=${PN/pp/++}
+COMMIT_ID="b34075b76835b778bb6b2ce0aa224afd9d182887"
+
+DESCRIPTION="A tool to integrate C/C++ code with Lua"
+HOMEPAGE="https://github.com/LuaDist/toluapp"
+SRC_URI="https://github.com/LuaDist/toluapp/archive/${COMMIT_ID}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+RDEPEND="${LUA_DEPS}"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}-${COMMIT_ID}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.93_p20190513-fix-multilib.patch
+ "${FILESDIR}"/${PN}-1.0.93_p20190513-lua-version.patch
+)
+CMAKE_REMOVE_MODULES_LIST="dist.cmake lua.cmake FindLua.cmake"
+
+src_configure() {
+ local mycmakeargs=(
+ -DLUA_VERSION=$(ver_cut 1-2 $(lua_get_version))
+ )
+ cmake_src_configure
+}