summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2020-11-04 12:00:29 -0500
committerMike Gilbert <floppym@gentoo.org>2020-11-04 12:00:29 -0500
commitcfb59fec099f9a978c736939932e9431756b4b35 (patch)
tree4249c81a247fddba5edf20b673090f8a441c13c1 /dev-lua
parentdev-libs/libfmt: Cleanup old version (diff)
downloadgentoo-cfb59fec099f9a978c736939932e9431756b4b35.tar.gz
gentoo-cfb59fec099f9a978c736939932e9431756b4b35.tar.bz2
gentoo-cfb59fec099f9a978c736939932e9431756b4b35.zip
dev-lua/lutok: rework LUA_CFLAGS and LUA_LIBS
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/lutok/lutok-0.4-r10.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/dev-lua/lutok/lutok-0.4-r10.ebuild b/dev-lua/lutok/lutok-0.4-r10.ebuild
index a88f7f0ef0ca..378ed963caf4 100644
--- a/dev-lua/lutok/lutok-0.4-r10.ebuild
+++ b/dev-lua/lutok/lutok-0.4-r10.ebuild
@@ -33,9 +33,13 @@ pkg_setup() {
src_configure() {
lua_setup
- lua_get_CFLAGS >/dev/null
- lua_get_LIBS >/dev/null
- econf --enable-shared --disable-static
+ local myconf=(
+ --enable-shared
+ --disable-static
+ LUA_CFLAGS="$(lua_get_CFLAGS)"
+ LUA_LIBS="$(lua_get_LIBS)"
+ )
+ econf "${myconf[@]}"
}
src_install() {