summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-27 09:11:25 +0000
committerSam James <sam@gentoo.org>2021-01-27 09:12:04 +0000
commit340691fa679eb56df7a4aa45e5569af72fe986ff (patch)
treebe71a62514c328ba27f59fab208fa3b6480fef4e /dev-ml/async_ssl/async_ssl-0.14.0.ebuild
parentdev-ml/async: bump to 0.14.0 (diff)
downloadgentoo-340691fa679eb56df7a4aa45e5569af72fe986ff.tar.gz
gentoo-340691fa679eb56df7a4aa45e5569af72fe986ff.tar.bz2
gentoo-340691fa679eb56df7a4aa45e5569af72fe986ff.zip
dev-ml/async_ssl: bump to 0.14.0
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml/async_ssl/async_ssl-0.14.0.ebuild')
-rw-r--r--dev-ml/async_ssl/async_ssl-0.14.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ml/async_ssl/async_ssl-0.14.0.ebuild b/dev-ml/async_ssl/async_ssl-0.14.0.ebuild
new file mode 100644
index 000000000000..fba5e18f5769
--- /dev/null
+++ b/dev-ml/async_ssl/async_ssl-0.14.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="An Async-pipe-based interface with OpenSSL."
+HOMEPAGE="https://github.com/janestreet/async_ssl"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ dev-lang/ocaml:=
+ dev-ml/async:=
+ dev-ml/base:=
+ dev-ml/core:=
+ dev-ml/dune-configurator:=
+ dev-ml/ppx_jane:=
+ dev-ml/stdio:=
+ dev-ml/ocaml-ctypes:=
+ dev-libs/openssl:0=
+"
+DEPEND="${RDEPEND}"