summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-01 16:59:59 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-02 10:37:46 +0200
commit7e8babd850f6bca379f8a5ba1d66ccb3e1dc06cc (patch)
tree1f31b7f8f9a383372009a43d6b15ee58c835e6d9 /dev-ml/bin-prot/bin-prot-0.9.0.ebuild
parentdev-ml/ppx_variants_conv: Bump to 0.9.0 (diff)
downloadgentoo-7e8babd850f6bca379f8a5ba1d66ccb3e1dc06cc.tar.gz
gentoo-7e8babd850f6bca379f8a5ba1d66ccb3e1dc06cc.tar.bz2
gentoo-7e8babd850f6bca379f8a5ba1d66ccb3e1dc06cc.zip
dev-ml/bin-prot: Bump to 0.9.0
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ml/bin-prot/bin-prot-0.9.0.ebuild')
-rw-r--r--dev-ml/bin-prot/bin-prot-0.9.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-ml/bin-prot/bin-prot-0.9.0.ebuild b/dev-ml/bin-prot/bin-prot-0.9.0.ebuild
new file mode 100644
index 000000000000..c4b2b1198563
--- /dev/null
+++ b/dev-ml/bin-prot/bin-prot-0.9.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Binary protocol generator"
+HOMEPAGE="https://github.com/janestreet/bin_prot"
+SRC_URI="https://github.com/janestreet/bin_prot/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-lang/ocaml:=
+ dev-ml/base:=
+ dev-ml/ppx_compare:=
+ dev-ml/ppx_custom_printf:=
+ dev-ml/ppx_driver:=
+ dev-ml/ppx_fields_conv:=
+ dev-ml/ppx_sexp_conv:=
+ dev-ml/ppx_variants_conv:=
+ dev-ml/sexplib:=
+ dev-ml/ocaml-migrate-parsetree:=
+"
+DEPEND="${RDEPEND} dev-ml/opam dev-ml/jbuilder"
+
+S="${WORKDIR}/bin_prot-${PV}"
+
+src_test() {
+ jbuilder runtest || die
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN/-/_}.install || die
+ dodoc CHANGES.md README.md
+}