summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-07-28 10:35:15 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-07-29 12:05:38 +0200
commiteead0cfadf975e2a5ac4400c4b057722e31df8d0 (patch)
tree14ff7f9ea3b2be09d24098fec3f75a6e805af496 /dev-ml/bin-prot/bin-prot-0.9.1.ebuild
parentdev-ml/ppx_inline_test: bump to 0.9.2 (diff)
downloadgentoo-eead0cfadf975e2a5ac4400c4b057722e31df8d0.tar.gz
gentoo-eead0cfadf975e2a5ac4400c4b057722e31df8d0.tar.bz2
gentoo-eead0cfadf975e2a5ac4400c4b057722e31df8d0.zip
dev-ml/bin-prot: bump to 0.9.1
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-ml/bin-prot/bin-prot-0.9.1.ebuild')
-rw-r--r--dev-ml/bin-prot/bin-prot-0.9.1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-ml/bin-prot/bin-prot-0.9.1.ebuild b/dev-ml/bin-prot/bin-prot-0.9.1.ebuild
new file mode 100644
index 000000000000..5c2d435fef0b
--- /dev/null
+++ b/dev-ml/bin-prot/bin-prot-0.9.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Binary protocol generator"
+HOMEPAGE="https://github.com/janestreet/bin_prot"
+SRC_URI="https://github.com/janestreet/bin_prot/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-lang/ocaml:=
+ dev-ml/base:=
+ dev-ml/ppx_compare:=
+ dev-ml/ppx_custom_printf:=
+ dev-ml/ppx_core:=
+ dev-ml/ppx_driver:=
+ dev-ml/ppx_fields_conv:=
+ dev-ml/ppx_sexp_conv:=
+ dev-ml/ppx_type_conv:=
+ dev-ml/ppx_variants_conv:=
+ dev-ml/sexplib:=
+ dev-ml/ocaml-migrate-parsetree:=
+"
+DEPEND="${RDEPEND} dev-ml/opam dev-ml/jbuilder"
+
+S="${WORKDIR}/bin_prot-${PV}"
+
+src_test() {
+ jbuilder runtest || die
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN/-/_}.install || die
+ dodoc CHANGES.md README.md
+}