summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-02-05 19:01:56 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-02-05 21:59:02 +0100
commit295475730c0b20fbed5cf21f64d68b240d394511 (patch)
treefc856a4fa9c12d17fa4183506fa892a1e15e92a9 /dev-ml/bin-prot/bin-prot-113.24.00.ebuild
parentdev-ml/ppx_optcomp: use proper install method. (diff)
downloadgentoo-295475730c0b20fbed5cf21f64d68b240d394511.tar.gz
gentoo-295475730c0b20fbed5cf21f64d68b240d394511.tar.bz2
gentoo-295475730c0b20fbed5cf21f64d68b240d394511.zip
dev-ml/bin-prot: use proper install method
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml/bin-prot/bin-prot-113.24.00.ebuild')
-rw-r--r--dev-ml/bin-prot/bin-prot-113.24.00.ebuild20
1 files changed, 19 insertions, 1 deletions
diff --git a/dev-ml/bin-prot/bin-prot-113.24.00.ebuild b/dev-ml/bin-prot/bin-prot-113.24.00.ebuild
index ab1cf7b4ca71..e10bfb91fe0e 100644
--- a/dev-ml/bin-prot/bin-prot-113.24.00.ebuild
+++ b/dev-ml/bin-prot/bin-prot-113.24.00.ebuild
@@ -21,7 +21,25 @@ IUSE="doc"
RDEPEND=">=dev-ml/type-conv-109.28.00:="
DEPEND="${RDEPEND}
+ dev-ml/opam
test? ( >=dev-ml/ounit-1.1.2 )"
-DOCS=( "README.md" "CHANGES.md" )
S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ emake setup.exe
+ OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN/-/_}.install || die
+ dodoc CHANGES.md README.md
+}