summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-07-11 12:26:55 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-07-11 12:30:14 +0200
commitcd6a24c9a2bfc66f9a30e10742ff65f2bb272763 (patch)
treeb813f119a7df609960aa9f0f18a3a6f6703c0974 /dev-ml/biniou/biniou-1.0.12.ebuild
parentdev-ml/ocaml-redis: bump to 0.3.0 (diff)
downloadgentoo-cd6a24c9a2bfc66f9a30e10742ff65f2bb272763.tar.gz
gentoo-cd6a24c9a2bfc66f9a30e10742ff65f2bb272763.tar.bz2
gentoo-cd6a24c9a2bfc66f9a30e10742ff65f2bb272763.zip
dev-ml/biniou: bump to 1.0.12; update homepage & src_uri
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ml/biniou/biniou-1.0.12.ebuild')
-rw-r--r--dev-ml/biniou/biniou-1.0.12.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ml/biniou/biniou-1.0.12.ebuild b/dev-ml/biniou/biniou-1.0.12.ebuild
new file mode 100644
index 000000000000..8f403bb521d2
--- /dev/null
+++ b/dev-ml/biniou/biniou-1.0.12.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="A binary data serialization format inspired by JSON for OCaml"
+HOMEPAGE="https://github.com/mjambon/biniou"
+SRC_URI="https://github.com/mjambon/biniou/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0/${PV}"
+LICENSE="BSD"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+RDEPEND=">=dev-lang/ocaml-3.11:=[ocamlopt?]
+ dev-ml/easy-format:=[ocamlopt?]
+"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ emake all
+ use ocamlopt && emake opt
+}
+
+src_install() {
+ use ocamlopt && dodir /usr/bin
+ findlib_src_install BINDIR="${ED}"/usr/bin
+ dodoc README.md Changes
+}