summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-05-08 11:25:26 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-05-08 12:18:46 +0200
commitcea948364fd56e8989b441c871ec78793b29eb12 (patch)
tree25282be2f0a87b751ee1d6b0d5556caf07ce89d1 /dev-ml/biniou/biniou-1.0.13.ebuild
parentnet-analyzer/pbgpp: Initial commit, ebuild by and review by David "Soap" Seif... (diff)
downloadgentoo-cea948364fd56e8989b441c871ec78793b29eb12.tar.gz
gentoo-cea948364fd56e8989b441c871ec78793b29eb12.tar.bz2
gentoo-cea948364fd56e8989b441c871ec78793b29eb12.zip
dev-ml/biniou: bump to 1.0.13
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ml/biniou/biniou-1.0.13.ebuild')
-rw-r--r--dev-ml/biniou/biniou-1.0.13.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ml/biniou/biniou-1.0.13.ebuild b/dev-ml/biniou/biniou-1.0.13.ebuild
new file mode 100644
index 000000000000..221435a17637
--- /dev/null
+++ b/dev-ml/biniou/biniou-1.0.13.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="A binary data serialization format inspired by JSON for OCaml"
+HOMEPAGE="https://github.com/mjambon/biniou"
+SRC_URI="https://github.com/mjambon/biniou/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0/${PV}"
+LICENSE="BSD"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+RDEPEND=">=dev-lang/ocaml-3.11:=[ocamlopt?]
+ dev-ml/easy-format:=[ocamlopt?]
+"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ emake all
+ use ocamlopt && emake opt
+}
+
+src_install() {
+ use ocamlopt && dodir /usr/bin
+ findlib_src_install BINDIR="${ED}"/usr/bin
+ dodoc README.md Changes
+}