summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-06-20 23:31:08 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-06-20 23:31:08 +0200
commitb90ef0cb96667e97cc7f02d0581825b8ef12b5f6 (patch)
tree8ca56209c66eb1c42a9164250b1b5314d58afb96 /dev-ml/bos
parentdev-ml/fpath: initial import (diff)
downloadgentoo-b90ef0cb96667e97cc7f02d0581825b8ef12b5f6.tar.gz
gentoo-b90ef0cb96667e97cc7f02d0581825b8ef12b5f6.tar.bz2
gentoo-b90ef0cb96667e97cc7f02d0581825b8ef12b5f6.zip
dev-ml/bos: initial import
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-ml/bos')
-rw-r--r--dev-ml/bos/Manifest1
-rw-r--r--dev-ml/bos/bos-0.1.6.ebuild44
-rw-r--r--dev-ml/bos/metadata.xml11
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-ml/bos/Manifest b/dev-ml/bos/Manifest
new file mode 100644
index 000000000000..16b9abcf8060
--- /dev/null
+++ b/dev-ml/bos/Manifest
@@ -0,0 +1 @@
+DIST bos-0.1.6.tbz 39822 SHA256 9abe76e0d94d1d912f0057dc3976c88d87ab9d5ba05d923c38c7b586e35f3afd SHA512 f1f10a97a32da936a7d5a0c70632e723723ee523c79f9dfd23bc42c039a194e8d69658483e6e856c7911332b799a92bf8cabfe96cc387522d7450b8f3f8f8343 WHIRLPOOL 0f2fca003dde8aebee99c5ab590e4f9e527eaa17464bd34b4c31a37c39e4b06c25568d4254028cd11a6328a93ffd96d161d9188deaffb82499943cd69960e9ea
diff --git a/dev-ml/bos/bos-0.1.6.ebuild b/dev-ml/bos/bos-0.1.6.ebuild
new file mode 100644
index 000000000000..a3b7dc553e2e
--- /dev/null
+++ b/dev-ml/bos/bos-0.1.6.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Basic OS interaction for OCaml"
+HOMEPAGE="http://erratique.ch/software/bos https://github.com/dbuenzli/bos"
+SRC_URI="http://erratique.ch/software/bos/releases/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ dev-lang/ocaml:=
+ dev-ml/rresult:=
+ dev-ml/astring:=
+ dev-ml/fpath:=
+ dev-ml/fmt:=
+ dev-ml/logs:=
+"
+DEPEND="${RDEPEND}
+ dev-ml/findlib
+ dev-ml/ocamlbuild
+ dev-ml/topkg
+ test? ( dev-ml/mtime )
+"
+
+src_compile() {
+ ocaml pkg/pkg.ml build --tests $(usex test true false) || die
+}
+
+src_test() {
+ ocaml pkg/pkg.ml test || die
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+}
diff --git a/dev-ml/bos/metadata.xml b/dev-ml/bos/metadata.xml
new file mode 100644
index 000000000000..9b594d778b1e
--- /dev/null
+++ b/dev-ml/bos/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+</maintainer>
+ <upstream>
+ <remote-id type="github">dbuenzli/bos</remote-id>
+ </upstream>
+</pkgmetadata>