summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-11-18 01:26:20 +0000
committerSam James <sam@gentoo.org>2020-11-18 01:26:20 +0000
commitb3b370b4fbb281b0d3b3531abedb3b8305565929 (patch)
tree395495cbfbe5216fbd2086080bf44f02ece8b40c /dev-ml/camldbm/camldbm-1.2.ebuild
parentdev-ml/camldbm: port to EAPI 7 (diff)
downloadgentoo-b3b370b4fbb281b0d3b3531abedb3b8305565929.tar.gz
gentoo-b3b370b4fbb281b0d3b3531abedb3b8305565929.tar.bz2
gentoo-b3b370b4fbb281b0d3b3531abedb3b8305565929.zip
dev-ml/camldbm: bump to 1.2
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml/camldbm/camldbm-1.2.ebuild')
-rw-r--r--dev-ml/camldbm/camldbm-1.2.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ml/camldbm/camldbm-1.2.ebuild b/dev-ml/camldbm/camldbm-1.2.ebuild
new file mode 100644
index 000000000000..4bae2351d3f3
--- /dev/null
+++ b/dev-ml/camldbm/camldbm-1.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="OCaml binding to the NDBM/GDBM Unix databases"
+HOMEPAGE="https://github.com/ocaml/dbm"
+SRC_URI="https://github.com/ocaml/dbm/archive/${P}.tar.gz"
+S="${WORKDIR}/dbm-${P}"
+
+LICENSE="LGPL-2-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+
+DEPEND=">=sys-libs/gdbm-1.9.1-r2[berkdb]
+ >=dev-lang/ocaml-3.12:=[ocamlopt]"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ dodir "$(ocamlc -where)/stublibs" # required and makefile does not create it
+ emake LIBDIR="${D}/$(ocamlc -where)" install
+}