summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-12-21 00:19:58 -0600
committerTim Harder <radhermit@gentoo.org>2018-12-21 01:47:54 -0600
commitce776ee40c63c35a72fc1db8eb07357aa19c078a (patch)
tree16996bd0b2870fdce1e26e1a5b7ab20b6ccafb99 /dev-ml/camlpdf/camlpdf-2.2.1.ebuild
parentdev-python/idna-ssl: version bump to 1.1.0 (diff)
downloadgentoo-ce776ee40c63c35a72fc1db8eb07357aa19c078a.tar.gz
gentoo-ce776ee40c63c35a72fc1db8eb07357aa19c078a.tar.bz2
gentoo-ce776ee40c63c35a72fc1db8eb07357aa19c078a.zip
dev-ml/camlpdf: version bump to 2.2.1
Force ocamlopt to be enabled. Closes: https://bugs.gentoo.org/535824 Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'dev-ml/camlpdf/camlpdf-2.2.1.ebuild')
-rw-r--r--dev-ml/camlpdf/camlpdf-2.2.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ml/camlpdf/camlpdf-2.2.1.ebuild b/dev-ml/camlpdf/camlpdf-2.2.1.ebuild
new file mode 100644
index 000000000000..f6709f295c68
--- /dev/null
+++ b/dev-ml/camlpdf/camlpdf-2.2.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit findlib
+
+DESCRIPTION="OCaml library for reading, writing, and modifying PDF files"
+HOMEPAGE="https://github.com/johnwhitington/camlpdf/"
+SRC_URI="https://github.com/johnwhitington/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+# technically LGPL-2.1+ with linking exception
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND="dev-lang/ocaml:=[ocamlopt]"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ # parallel make bugs
+ emake -j1
+}
+
+src_install() {
+ findlib_src_install
+ dodoc Changes README.md
+
+ if use doc ; then
+ dodoc introduction_to_camlpdf.pdf
+ dodoc -r doc/camlpdf/html
+ fi
+
+ use examples && dodoc -r examples
+}