summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-10-12 09:56:40 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-10-12 09:56:54 +0200
commit5ceffb7d9b71aac7eed92ca0ee9db3a457165827 (patch)
tree85686970d8e2f55d452efefbe1f97aab6b178dbc /dev-ml/cmdliner/cmdliner-0.9.8.ebuild
parentmedia-video/x264-encoder: remove old. (diff)
downloadgentoo-5ceffb7d9b71aac7eed92ca0ee9db3a457165827.tar.gz
gentoo-5ceffb7d9b71aac7eed92ca0ee9db3a457165827.tar.bz2
gentoo-5ceffb7d9b71aac7eed92ca0ee9db3a457165827.zip
dev-ml/cmdliner: bump to 0.9.8
Package-Manager: portage-2.2.23
Diffstat (limited to 'dev-ml/cmdliner/cmdliner-0.9.8.ebuild')
-rw-r--r--dev-ml/cmdliner/cmdliner-0.9.8.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ml/cmdliner/cmdliner-0.9.8.ebuild b/dev-ml/cmdliner/cmdliner-0.9.8.ebuild
new file mode 100644
index 000000000000..87faba390088
--- /dev/null
+++ b/dev-ml/cmdliner/cmdliner-0.9.8.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Declarative definition of command line interfaces for OCaml"
+HOMEPAGE="http://erratique.ch/software/cmdliner"
+SRC_URI="http://erratique.ch/software/${PN}/releases/${P}.tbz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="doc +ocamlopt"
+
+DEPEND=">=dev-lang/ocaml-4:=[ocamlopt?]"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ ocaml pkg/build.ml \
+ native=$(usex ocamlopt true false) \
+ native-dynlink=$(usex ocamlopt true false) \
+ || die
+}
+
+src_install() {
+ # Can't use opam-installer here as it is an opam dep...
+ findlib_src_preinst
+ local nativelibs=""
+ use ocamlopt && nativelibs="$(echo _build/src/cmdliner.cm{x,xa,xs} _build/src/cmdliner.a)"
+ ocamlfind install cmdliner _build/pkg/META \
+ _build/src/cmdliner.mli _build/src/cmdliner.cm{a,i} ${nativelibs} || die
+ dodoc README.md TODO.md CHANGES.md
+ use doc && dohtml -r doc/
+}