summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-25 18:28:21 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-25 19:32:17 +0200
commitd655259576d18ba2caf5a30ab16f443cdaec372d (patch)
tree443974429a9a6281590a3d8899759c55bd016d12 /dev-ml/cppo/cppo-1.5.0.ebuild
parentapp-misc/ranger: version bump to 1.9.0_beta5 (diff)
downloadgentoo-d655259576d18ba2caf5a30ab16f443cdaec372d.tar.gz
gentoo-d655259576d18ba2caf5a30ab16f443cdaec372d.tar.bz2
gentoo-d655259576d18ba2caf5a30ab16f443cdaec372d.zip
dev-ml/cppo: bump to 1.5.0
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ml/cppo/cppo-1.5.0.ebuild')
-rw-r--r--dev-ml/cppo/cppo-1.5.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ml/cppo/cppo-1.5.0.ebuild b/dev-ml/cppo/cppo-1.5.0.ebuild
new file mode 100644
index 000000000000..933faf0db619
--- /dev/null
+++ b/dev-ml/cppo/cppo-1.5.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit findlib
+
+DESCRIPTION="An equivalent of the C preprocessor for OCaml programs"
+HOMEPAGE="http://mjambon.com/cppo.html https://github.com/mjambon/cppo/"
+SRC_URI="https://github.com/mjambon/cppo/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0/${PV}"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+
+IUSE="examples"
+
+RDEPEND=">=dev-lang/ocaml-3.12:=
+ dev-ml/ocamlbuild:="
+DEPEND="${RDEPEND}"
+
+src_install() {
+ findlib_src_preinst
+ mkdir -p "${ED}"/usr/bin
+ emake PREFIX="${ED}"/usr install
+ dodoc README.md Changes
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}