summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-10-17 08:02:44 +0000
committerSam James <sam@gentoo.org>2020-10-17 08:02:59 +0000
commitbcd82d37b83a0d855c1dfd3ec65f08ffdbff069d (patch)
tree252b63b86f676a142330d4d4676374c80c347cbd /dev-ml/cryptokit
parentsys-apps/iproute2: Bump to version 5.9.0 (diff)
downloadgentoo-bcd82d37b83a0d855c1dfd3ec65f08ffdbff069d.tar.gz
gentoo-bcd82d37b83a0d855c1dfd3ec65f08ffdbff069d.tar.bz2
gentoo-bcd82d37b83a0d855c1dfd3ec65f08ffdbff069d.zip
dev-ml/cryptokit: bump to 1.16.1
Closes: https://bugs.gentoo.org/625938 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml/cryptokit')
-rw-r--r--dev-ml/cryptokit/Manifest1
-rw-r--r--dev-ml/cryptokit/cryptokit-1.16.1.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-ml/cryptokit/Manifest b/dev-ml/cryptokit/Manifest
index 7876c2395d34..79a52bbbc284 100644
--- a/dev-ml/cryptokit/Manifest
+++ b/dev-ml/cryptokit/Manifest
@@ -1,3 +1,4 @@
DIST cryptokit-1.10.tar.gz 152525 BLAKE2B 51c905757ad141292be89707bdab5c83a1f3e9e2665202cbf17e12b115591c57b77b759b4fa2967d1f00b4cf5bd87445a2189b4d222d5d1613e19c32e1054189 SHA512 22564e0151c492963d75fb81780b3a884a0bf613ad09380d9b5365740fd9c4bbdaa1c21fed50a1a4934dce920d90f5c86dc014f90e52677544789311f7bded4f
DIST cryptokit-1.11.tar.gz 156905 BLAKE2B 3fc77321c0d525a32f5733d77963b5df4e618b3168f2f00aceeb1e13b16cc202e79b50afa93c0769f016b4e43061ff19851c8ba3f40ad7f8f0c9ff78a51d68e7 SHA512 cc641a05a67cd3d2e5ec481e8d426796db625ab60e89f79bde2e360730892c62f30ea2e37c4b028df16471220847e6d7ce4984deb9528fec6647a17fc4ae1b0d
DIST cryptokit-1.12.tar.gz 157920 BLAKE2B c26d0642f02cf19502bfce043bfb542bfb7a8e80ac2c7dfbecce48b57d44eddd5f279ceec1166fd2e81e1a8446bb52fa748d89a3f7506860fe1c545784087469 SHA512 f99c50578360c7671029a0c4603b355912899596ea7baf55cb2f94e039658646396f1307417a24b3d87a535d272bed90e79d5e027af034c2c742140c44ec61ff
+DIST cryptokit-1.16.1.tar.gz 120607 BLAKE2B fbb89c4dabef8f09614003acc2b8173fdfdacb36793fd20f4415ebec04f3759537739eccd7b9d143df0163816b9db65c221c2b83408c9ac3aa7f9bf7b63876c6 SHA512 28913a7c35ae951a4c464287acc511ee1bdc9d03b5928e2243c5ae5cbb8b10afe8e84d7a73ba6478ed62657d01fdb6f02472739255c33de3671c4130b659da52
diff --git a/dev-ml/cryptokit/cryptokit-1.16.1.ebuild b/dev-ml/cryptokit/cryptokit-1.16.1.ebuild
new file mode 100644
index 000000000000..03351f2cf739
--- /dev/null
+++ b/dev-ml/cryptokit/cryptokit-1.16.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+MY_PV="$(ver_rs 1- '')"
+DESCRIPTION="Cryptographic primitives library for Objective Caml"
+HOMEPAGE="https://github.com/xavierleroy/cryptokit"
+SRC_URI="https://github.com/xavierleroy/cryptokit/archive/release${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-release${MY_PV}"
+
+LICENSE="LGPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="cpu_flags_x86_aes +ocamlopt test zlib"
+REQUIRED_USE="test? ( ocamlopt )"
+
+DEPEND="
+ dev-ml/zarith:=
+ zlib? ( >=sys-libs/zlib-1.1 )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( "Changes" "README.txt" "AUTHORS.txt" )
+
+src_configure() {
+ # Don't build in src_configure
+ sed -i -e 's:exit (Sys.command "dune build @configure --release")::' configure || die
+
+ # It's not autotools (or even close), it's a Dune wrapper.
+ ./configure \
+ $(use_enable cpu_flags_x86_aes hardwaresupport) \
+ $(use_enable zlib) \
+ || die
+}
+
+pkg_postinst() {
+ elog ""
+ elog "This library uses the /dev/random device to generate "
+ elog "random data and RSA keys. The device should either be"
+ elog "built into the kernel or provided as a module. An"
+ elog "alternative is to use the Entropy Gathering Daemon"
+ elog "(http://egd.sourceforge.net). Please note that the"
+ elog "remainder of the library will still work even in the"
+ elog "absence of a one of these sources of randomness."
+ elog ""
+}
+
+src_test() {
+ echo ""
+ einfo "You must have either /dev/random or the Entropy Gathering"
+ einfo "Daemon (EGD) for this test to succeed!"
+ echo ""
+
+ dune_src_test
+}