summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ml/deriving
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ml/deriving')
-rw-r--r--dev-ml/deriving/Manifest2
-rw-r--r--dev-ml/deriving/deriving-0.6.2.ebuild28
-rw-r--r--dev-ml/deriving/deriving-0.7.ebuild36
-rw-r--r--dev-ml/deriving/metadata.xml8
4 files changed, 74 insertions, 0 deletions
diff --git a/dev-ml/deriving/Manifest b/dev-ml/deriving/Manifest
new file mode 100644
index 000000000000..fa17edea5b14
--- /dev/null
+++ b/dev-ml/deriving/Manifest
@@ -0,0 +1,2 @@
+DIST deriving-0.6.2.tar.gz 62722 SHA256 467995a27ad84ef70289bf168507741c635aa1c839c450f20671f93e469a9968 SHA512 f5e14737af085e0f9d2b6a7981d9f63435750fb9cf32401eeaf7f700d0e222e1e5ec647d8a552f8c16ad136da19396d4aea8e739ecf179a6c8ba09b035497fc1 WHIRLPOOL c1f29cfc18e6676a9469b655f202ebab1b6b86c7d867ba3061ac9a07279885d07b5d3a19a3f2766dc8d2a5f9d021c24e82cf71cf08fdb0a84ddb135c475dace4
+DIST deriving-0.7.tar.gz 68471 SHA256 0a26763f8579a558fb3bbc8268bd009208165131b66afd5b5c03e0cff73f2e6c SHA512 c473106aeb36888ff80070ce3646f19a603cee15dcc8d702efdb3d6ac91dd409e94fa36940cb6289004238c130631efe680344324904815c2bf380f28a6c3b79 WHIRLPOOL 9c35cc69fe17f3a0178f8907a66cf610d6c234e11fa7041171a490858ab7542d632ea2e97da08a97d6cbdce0fd322433d577d513dd160b816efd839a0dce01d5
diff --git a/dev-ml/deriving/deriving-0.6.2.ebuild b/dev-ml/deriving/deriving-0.6.2.ebuild
new file mode 100644
index 000000000000..6935c1487d85
--- /dev/null
+++ b/dev-ml/deriving/deriving-0.6.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="A deriving library for Ocsigen"
+HOMEPAGE="http://github.com/ocsigen/deriving"
+SRC_URI="http://github.com/ocsigen/deriving/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ >=dev-ml/type-conv-108:=
+ dev-ml/optcomp:=
+"
+DEPEND="${RDEPEND}
+ dev-ml/oasis"
+
+DOCS=( CHANGES README.md )
+oasis_configure_opts=( --enable-tc )
diff --git a/dev-ml/deriving/deriving-0.7.ebuild b/dev-ml/deriving/deriving-0.7.ebuild
new file mode 100644
index 000000000000..7f8b26b12a67
--- /dev/null
+++ b/dev-ml/deriving/deriving-0.7.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="A deriving library for Ocsigen"
+HOMEPAGE="http://github.com/ocsigen/deriving"
+SRC_URI="http://github.com/ocsigen/deriving/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ >=dev-ml/type-conv-108:=
+ dev-ml/optcomp:=
+ dev-ml/findlib:=
+ dev-ml/camlp4:=
+"
+DEPEND="${RDEPEND}
+ dev-ml/oasis"
+
+DOCS=( CHANGES README.md )
+oasis_configure_opts="--enable-tc"
+OASIS_SETUP_COMMAND="./setup.exe"
+
+src_configure() {
+ emake setup.exe
+ oasis_src_configure
+}
diff --git a/dev-ml/deriving/metadata.xml b/dev-ml/deriving/metadata.xml
new file mode 100644
index 000000000000..09825ef62a07
--- /dev/null
+++ b/dev-ml/deriving/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ml</herd>
+ <upstream>
+ <remote-id type="github">ocsigen/deriving</remote-id>
+ </upstream>
+</pkgmetadata>