summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-03-28 09:12:35 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-03-28 09:12:35 +0200
commit5920fe2a95ab2797eba5dae7c9f1e660c8b37f65 (patch)
treed8c91c361e11d3f047f33f7d9b06be9919873e36 /dev-ml/facile/facile-1.1.2.ebuild
parentdev-ros/eigen_stl_containers: bump to 0.1.5 (diff)
downloadgentoo-5920fe2a95ab2797eba5dae7c9f1e660c8b37f65.tar.gz
gentoo-5920fe2a95ab2797eba5dae7c9f1e660c8b37f65.tar.bz2
gentoo-5920fe2a95ab2797eba5dae7c9f1e660c8b37f65.zip
dev-ml/facile: bump to 1.1.2
Package-Manager: portage-2.2.28 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml/facile/facile-1.1.2.ebuild')
-rw-r--r--dev-ml/facile/facile-1.1.2.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-ml/facile/facile-1.1.2.ebuild b/dev-ml/facile/facile-1.1.2.ebuild
new file mode 100644
index 000000000000..62aba489c27a
--- /dev/null
+++ b/dev-ml/facile/facile-1.1.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="A constraint programming library on integer and integer set finite domains written in OCaml"
+HOMEPAGE="http://www.recherche.enac.fr/log/facile/"
+SRC_URI="http://www.recherche.enac.fr/log/facile/distrib/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="+ocamlopt"
+
+RDEPEND=">=dev-lang/ocaml-4:=[ocamlopt?]"
+DEPEND="${RDEPEND}
+ sys-apps/sed"
+
+src_prepare() {
+ # Fix building on FreeBSD
+ epatch "${FILESDIR}/${PN}"-1.1-make.patch
+ # Disable building native code objects if we dont have/want ocamlopt
+ if ! use ocamlopt; then
+ sed -i -e 's/\.opt//' src/Makefile || die "failed to change native code compiler to bytecode ones"
+ sed -i -e 's/ facile\.cmxa//' src/Makefile || die "failed to remove native code objects"
+ sed -i -e 's/\.opt/.out/g' \
+ -e 's: src/facile\.cmxa::'\
+ -e 's: src/facile\.a::'\
+ -e 's:^.*facile\.cmxa::'\
+ -e 's:^.*facile\.a::' Makefile || die "failed to remove native code objects"
+ fi
+}
+
+src_configure(){
+ # This is a custom configure script and it does not support standard options
+ ./configure --faciledir "${D}"$(ocamlc -where)/facile/ || die
+}
+
+src_test() {
+ emake check
+}
+
+src_install(){
+ dodir $(ocamlc -where)
+ emake install
+ dodoc README
+}