summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ml/facile/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ml/facile/files')
-rw-r--r--dev-ml/facile/files/facile-1.1-make.patch48
-rw-r--r--dev-ml/facile/files/facile-1.1-ocaml4.patch29
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-ml/facile/files/facile-1.1-make.patch b/dev-ml/facile/files/facile-1.1-make.patch
new file mode 100644
index 000000000000..7b77639d2277
--- /dev/null
+++ b/dev-ml/facile/files/facile-1.1-make.patch
@@ -0,0 +1,48 @@
+diff -ur a/Makefile b/Makefile
+--- a/Makefile 2004-09-08 10:51:02 +0100
++++ b/Makefile 2007-10-23 13:11:28 +0100
+@@ -3,7 +3,7 @@
+ include config_Makefile
+
+ compile:
+- cd src; make
++ cd src; $(MAKE)
+
+ install:
+ if test -d $(FACILEDIR); then : ; else mkdir $(FACILEDIR); fi
+@@ -14,10 +14,10 @@
+ chmod a+r $(FACILEDIR)/facile.a
+
+ clean:
+- cd src; make clean
++ cd src; $(MAKE) clean
+
+ distclean uninstall:
+ rm -fr $(FACILEDIR)
+
+ check:
+- cd examples; make FACILEDIR=../src queens.opt; ./queens.opt 8
++ cd examples; $(MAKE) FACILEDIR=../src queens.opt; ./queens.opt 8
+diff -ur a/src/Makefile b/src/Makefile
+--- a/src/Makefile 2004-09-08 10:51:02 +0100
++++ b/src/Makefile 2007-10-23 13:10:34 +0100
+@@ -28,7 +28,7 @@
+ # Version of the library to be linked with the -p (profiler) option
+ facile.p.cmxa : $(CSTR)
+ rm -fr $(CSTRCMX)
+- make facile.cmxa OPTOPT=-p
++ $(MAKE) facile.cmxa OPTOPT=-p
+ rm -fr $(CSTRCMX)
+ mv facile.cmxa $@
+ mv facile.a facile.p.a
+@@ -41,8 +41,8 @@
+ # Does not work with many modules (e.g. containing class expressions
+ facile.exp.cmxa : $(CSTR)
+ rm -fr $(CSTRCMX)
+- make fcl_stak.cmx fcl_cstr.cmx fcl_inv.cmx fcl_reify.cmx fcl_arith.cmx fcl_goals.cmx fcl_fdArray.cmx fcl_gcc.cmx fcl_alldiff.cmx fcl_sorting.cmx fcl_interval.cmx facile.cmx
+- make facile.cmxa OPTOPT="-pp inline_functors"
++ $(MAKE) fcl_stak.cmx fcl_cstr.cmx fcl_inv.cmx fcl_reify.cmx fcl_arith.cmx fcl_goals.cmx fcl_fdArray.cmx fcl_gcc.cmx fcl_alldiff.cmx fcl_sorting.cmx fcl_interval.cmx facile.cmx
++ $(MAKE) facile.cmxa OPTOPT="-pp inline_functors"
+ rm -fr $(CSTRCMX)
+ mv facile.cmxa $@
+ mv facile.a facile.exp.a
diff --git a/dev-ml/facile/files/facile-1.1-ocaml4.patch b/dev-ml/facile/files/facile-1.1-ocaml4.patch
new file mode 100644
index 000000000000..3c7556312364
--- /dev/null
+++ b/dev-ml/facile/files/facile-1.1-ocaml4.patch
@@ -0,0 +1,29 @@
+Index: facile-1.1/src/facile.mli
+===================================================================
+--- facile-1.1.orig/src/facile.mli
++++ facile-1.1/src/facile.mli
+@@ -127,7 +127,7 @@ module Data :
+ module Hashtbl :
+ sig
+ type ('a, 'b) t
+- val create : int -> ('a, 'b) t
++ val create : ?random:bool -> int -> ('a, 'b) t
+ val get : ('a, 'b) t -> ('a, 'b) Hashtbl.t
+ val add : ('a, 'b) t -> 'a -> 'b -> unit
+ val find : ('a, 'b) t -> 'a -> 'b
+Index: facile-1.1/src/fcl_data.cmi
+===================================================================
+Binary files facile-1.1.orig/src/fcl_data.cmi and facile-1.1/src/fcl_data.cmi differ
+Index: facile-1.1/src/fcl_data.mli
+===================================================================
+--- facile-1.1.orig/src/fcl_data.mli
++++ facile-1.1/src/fcl_data.mli
+@@ -23,7 +23,7 @@ end
+
+ module Hashtbl : sig
+ type ('a, 'b) t
+- val create : int -> ('a, 'b) t
++ val create : ?random:bool -> int -> ('a, 'b) t
+ val get : ('a, 'b) t -> ('a, 'b) Hashtbl.t
+ val add : ('a, 'b) t -> 'a -> 'b -> unit
+ val find : ('a, 'b) t -> 'a -> 'b