summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2019-12-27 18:58:54 +0100
committerJason A. Donenfeld <zx2c4@gentoo.org>2019-12-27 19:07:23 +0100
commitfabc73e63a16dfea2dc43652a8c952fb5f77f8e7 (patch)
treebf5a630559da0f9cf94fa393ab029aa37ef2b789 /dev-ml/findlib/findlib-1.8.1.ebuild
parentdev-haskell/bytestring-builder: drop docs (empty package) (diff)
downloadgentoo-fabc73e63a16dfea2dc43652a8c952fb5f77f8e7.tar.gz
gentoo-fabc73e63a16dfea2dc43652a8c952fb5f77f8e7.tar.bz2
gentoo-fabc73e63a16dfea2dc43652a8c952fb5f77f8e7.zip
dev-ml/findlib: bump to 1.8.1
This appears to be unmaintained, and the old ebuild no longer builds with new ocaml, but thankfully this newer findlib does. Let's bump it and see what happens. Fixes: https://bugs.gentoo.org/704012 Package-Manager: Portage-2.3.83, Repoman-2.3.20 Signed-off-by: Jason A. Donenfeld <zx2c4@gentoo.org>
Diffstat (limited to 'dev-ml/findlib/findlib-1.8.1.ebuild')
-rw-r--r--dev-ml/findlib/findlib-1.8.1.ebuild73
1 files changed, 73 insertions, 0 deletions
diff --git a/dev-ml/findlib/findlib-1.8.1.ebuild b/dev-ml/findlib/findlib-1.8.1.ebuild
new file mode 100644
index 000000000000..235cc886cff2
--- /dev/null
+++ b/dev-ml/findlib/findlib-1.8.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit multilib eutils
+
+DESCRIPTION="OCaml tool to find/use non-standard packages"
+HOMEPAGE="http://projects.camlcity.org/projects/findlib.html"
+SRC_URI="http://download.camlcity.org/download/${P}.tar.gz"
+IUSE="doc +ocamlopt tk"
+
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+DEPEND=">=dev-lang/ocaml-4.02.3-r1:=[ocamlopt?]
+ tk? ( dev-ml/labltk:= )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i 's/\$llabltk \$lcamlp4 \$lobuild//' configure || die "Unable to make meta external."
+ export ocamlfind_destdir="${EPREFIX}/usr/$(get_libdir)/ocaml"
+ export stublibs="${ocamlfind_destdir}/stublibs"
+}
+
+src_configure() {
+ local myconf
+ use tk && myconf="-with-toolbox"
+ ./configure -bindir "${EPREFIX}"/usr/bin -mandir "${EPREFIX}"/usr/share/man \
+ -sitelib ${ocamlfind_destdir} \
+ -config ${ocamlfind_destdir}/findlib/findlib.conf \
+ -no-custom \
+ ${myconf} || die "configure failed"
+}
+
+src_compile() {
+ emake -j1 all
+ if use ocamlopt; then
+ emake -j1 opt # optimized code
+ fi
+}
+
+src_install() {
+ emake prefix="${D}" install
+
+ dodir "${stublibs#${EPREFIX}}"
+
+ cd "${S}/doc"
+ dodoc QUICKSTART README DOCINFO
+ use doc && dohtml -r ref-html guide-html
+}
+
+check_stublibs() {
+ local ocaml_stdlib=`ocamlc -where`
+ local ldconf="${ocaml_stdlib}/ld.conf"
+
+ if [ ! -e ${ldconf} ]
+ then
+ echo "${ocaml_stdlib}" > ${ldconf}
+ echo "${ocaml_stdlib}/stublibs" >> ${ldconf}
+ fi
+
+ if [ -z `grep -e ${stublibs} ${ldconf}` ]
+ then
+ echo ${stublibs} >> ${ldconf}
+ fi
+}
+
+pkg_postinst() {
+ check_stublibs
+}