summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-07-25 14:42:04 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-07-25 15:12:21 +0200
commiteb09c13023a40e47c5d965630dde6c2f11a2dfd2 (patch)
tree7ffe84d4b54d7e4fb0d36eef0353a53e7e2c3ffb /dev-ml/flow_parser/flow_parser-0.51.0.ebuild
parentdev-ml/jbuilder: bump to 1.0_beta11 (diff)
downloadgentoo-eb09c13023a40e47c5d965630dde6c2f11a2dfd2.tar.gz
gentoo-eb09c13023a40e47c5d965630dde6c2f11a2dfd2.tar.bz2
gentoo-eb09c13023a40e47c5d965630dde6c2f11a2dfd2.zip
dev-ml/flow_parser: bump to 0.51.0
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-ml/flow_parser/flow_parser-0.51.0.ebuild')
-rw-r--r--dev-ml/flow_parser/flow_parser-0.51.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ml/flow_parser/flow_parser-0.51.0.ebuild b/dev-ml/flow_parser/flow_parser-0.51.0.ebuild
new file mode 100644
index 000000000000..a36131a0f030
--- /dev/null
+++ b/dev-ml/flow_parser/flow_parser-0.51.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit findlib
+
+DESCRIPTION="JavaScript parser written in OCaml"
+HOMEPAGE="https://github.com/facebook/flow/tree/master/src/parser"
+SRC_URI="https://github.com/facebook/flow/archive/v${PV}.tar.gz -> flow-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-lang/ocaml:=
+ dev-ml/sedlex:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ dev-ml/ocamlbuild"
+
+S="${WORKDIR}/flow-${PV}/src/parser"
+
+src_compile() {
+ emake build-parser
+}
+
+src_test() {
+ emake test-ocaml
+}
+
+src_install() {
+ findlib_src_preinst
+ emake ocamlfind-install
+ dodoc README.md
+}