summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-07-10 17:32:54 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-07-10 17:50:59 +0200
commit9b0fbfeaa793ce6360a1034e736174dbe374e781 (patch)
treef501da797f55ef0307e5515814619b70ccb45f4f /dev-ml/fmt
parentdev-ml/ocaml-ctypes: bump to 0.12.1 (diff)
downloadgentoo-9b0fbfeaa793ce6360a1034e736174dbe374e781.tar.gz
gentoo-9b0fbfeaa793ce6360a1034e736174dbe374e781.tar.bz2
gentoo-9b0fbfeaa793ce6360a1034e736174dbe374e781.zip
dev-ml/fmt: bump to 0.8.4
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-ml/fmt')
-rw-r--r--dev-ml/fmt/Manifest1
-rw-r--r--dev-ml/fmt/fmt-0.8.4.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-ml/fmt/Manifest b/dev-ml/fmt/Manifest
index 052475a9c1a1..1e2a4c0a1b86 100644
--- a/dev-ml/fmt/Manifest
+++ b/dev-ml/fmt/Manifest
@@ -1,2 +1,3 @@
DIST fmt-0.8.2.tbz 13668 SHA256 11a1b12037aea444b1ead54143bd0abde43752a57e1ac77dfeab98cac8f91808 SHA512 38f567a988176bb4628665e6f5e47dba4917a2f65310d222dcd7f14809a38fbd824e9ee05ba4de97a20aa2c57a813541c587c8c438b2ac1f93199dddaa441ae0 WHIRLPOOL 159c7d9dfe389707e6a566ae75c52cf4fb890d253c978baecb2ae9d93d03a06094e4e3098141bea9c6686143c53445449bc07bfec35922374cd3ae9774cccd98
DIST fmt-0.8.3.tbz 13918 SHA256 b942f20b42d8e10812843995bfef504e7eae3f605908c2d00cd59cf91d5e3aec SHA512 9c63c9a3ae72e5d18041fc1ed03d36f4cdf66847aa960014e682bd7d576df516db9638d9d9df6fcfcaa863d243d37044c4f74dcf9e2518bd4ce6be0fa3994aea WHIRLPOOL 436d8248d6d2266f98ba353672d0c4b5b189a5b031ba69284004ec35d93e51bd2913343651611132dcc72bfe633e42754684c1d1f4ed39eaf34164283edd5011
+DIST fmt-0.8.4.tbz 14079 SHA256 7b6304eb1b4a34fabeb456628eeb236ea3ff96dc34651516b21562ace3d234e2 SHA512 d17407f15447172ad444fa288b9a16962b0e4829cb73f62004b0f8dad2bec60a7911ad11fd05545d61d7fdb88099e53694548c73368399ba183c53383e1dfd31 WHIRLPOOL d8a30d7b6219ae656d3e21a86b39a3e345a4301ba26739d63b82d6b0d880a9128d34de523f7a3d96592ece7caea13f7ada27599cfbc0cfbb77d6efa073105d77
diff --git a/dev-ml/fmt/fmt-0.8.4.ebuild b/dev-ml/fmt/fmt-0.8.4.ebuild
new file mode 100644
index 000000000000..8e0f58572e56
--- /dev/null
+++ b/dev-ml/fmt/fmt-0.8.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit findlib
+
+DESCRIPTION="Combinators to devise OCaml Format pretty-printing functions"
+HOMEPAGE="http://erratique.ch/software/fmt https://github.com/dbuenzli/fmt"
+SRC_URI="http://erratique.ch/software/fmt/releases/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="dev-ml/result:=[ocamlopt]
+ dev-lang/ocaml:=[ocamlopt]
+ dev-ml/uchar:=[ocamlopt]
+ dev-ml/cmdliner:=[ocamlopt]"
+DEPEND="${RDEPEND}
+ dev-ml/opam
+ >=dev-ml/topkg-0.9
+ dev-ml/ocamlbuild
+ dev-ml/findlib"
+
+src_compile() {
+ ocaml pkg/pkg.ml build --tests $(usex test 'true' 'false') || die
+}
+
+src_test() {
+ ocaml pkg/pkg.ml test || die
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+ dodoc CHANGES.md README.md
+}