summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ml/gd4o
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ml/gd4o')
-rw-r--r--dev-ml/gd4o/Manifest1
-rw-r--r--dev-ml/gd4o/gd4o-1.0_alpha5.ebuild55
-rw-r--r--dev-ml/gd4o/metadata.xml8
3 files changed, 64 insertions, 0 deletions
diff --git a/dev-ml/gd4o/Manifest b/dev-ml/gd4o/Manifest
new file mode 100644
index 000000000000..662188b86ca0
--- /dev/null
+++ b/dev-ml/gd4o/Manifest
@@ -0,0 +1 @@
+DIST gd4o-1.0a5.tar.gz 885735 SHA256 fa10b60a785e6734b6ac1b5a762f496b925502cfc848381cae7dfb75fe547eed SHA512 f582ff5dc4ece692b779c78ea97d1df90768564ab172a3933196bc0d9eedf31a53ca01c4745d7eacc81f977611b509dd2f912fac08b1bf0f70ec03605a40a85b WHIRLPOOL 9b2fff948e4a832fff24c292323924a6d06380d417fbcf5bd0c5e44565409f99c5354b66f36a832b109d2b581751e480e9f79ff86fee835c9ec512c31f6044f8
diff --git a/dev-ml/gd4o/gd4o-1.0_alpha5.ebuild b/dev-ml/gd4o/gd4o-1.0_alpha5.ebuild
new file mode 100644
index 000000000000..0adf8973687c
--- /dev/null
+++ b/dev-ml/gd4o/gd4o-1.0_alpha5.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs findlib
+
+MY_P="${P/_alpha/a}"
+
+DESCRIPTION="OCaml interface to the GD graphics library"
+HOMEPAGE="http://sourceforge.net/projects/gd4o/"
+SRC_URI="mirror://sourceforge/gd4o/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="doc +ocamlopt"
+
+DEPEND=">=dev-lang/ocaml-3.10.2:=[ocamlopt?]
+ media-libs/gd
+ virtual/jpeg
+ sys-libs/zlib
+ media-libs/libpng
+ media-libs/freetype:2"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ sed -i 's/CFLAGS =/CFLAGS += -fPIC/' Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+ if use ocamlopt ; then
+ emake CC="$(tc-getCC)" opt
+ fi
+ if use doc ; then
+ emake docs
+ fi
+}
+
+src_test() {
+ emake test
+ if use ocamlopt ; then
+ emake test.opt
+ fi
+}
+
+src_install() {
+ findlib_src_install
+ dodoc BUGS CHANGES README* TODO doc/manual.txt
+ use doc && dohtml -r doc
+}
diff --git a/dev-ml/gd4o/metadata.xml b/dev-ml/gd4o/metadata.xml
new file mode 100644
index 000000000000..ae5d75598795
--- /dev/null
+++ b/dev-ml/gd4o/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ml</herd>
+ <upstream>
+ <remote-id type="sourceforge">gd4o</remote-id>
+ </upstream>
+</pkgmetadata>