summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-19 10:39:34 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-19 11:09:10 +0200
commite98baba1e4a672334dafef3ebe32651e79cb484b (patch)
tree90d3887215cbb4ee58706ea804f9d9d6c305a8c7 /dev-ml/iTeML/iTeML-2.6.ebuild
parentapp-misc/muttprint: Drops old version (diff)
downloadgentoo-e98baba1e4a672334dafef3ebe32651e79cb484b.tar.gz
gentoo-e98baba1e4a672334dafef3ebe32651e79cb484b.tar.bz2
gentoo-e98baba1e4a672334dafef3ebe32651e79cb484b.zip
dev-ml/iTeML: Bump to 2.6
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ml/iTeML/iTeML-2.6.ebuild')
-rw-r--r--dev-ml/iTeML/iTeML-2.6.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ml/iTeML/iTeML-2.6.ebuild b/dev-ml/iTeML/iTeML-2.6.ebuild
new file mode 100644
index 000000000000..90e9f8676bf7
--- /dev/null
+++ b/dev-ml/iTeML/iTeML-2.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Inline (Unit) Tests for OCaml"
+HOMEPAGE="https://github.com/vincent-hugot/iTeML"
+SRC_URI="https://github.com/vincent-hugot/iTeML/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-ml/ounit:=
+ dev-lang/ocaml:=[ocamlopt]
+ >=dev-ml/qcheck-0.5:=
+"
+DEPEND="${RDEPEND}
+ dev-ml/ocamlbuild
+"
+
+src_install() {
+ findlib_src_preinst
+ dodir /usr/bin
+ emake BIN="${ED}/usr/bin/" install
+ dodoc README.adoc HOWTO.adoc
+}