summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-06-22 14:46:29 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-06-22 16:24:34 +0200
commit0dc5e83d174cd5271de5c6829ee987844a9eb886 (patch)
tree02e20892f3aa1378db5377e4fb0655f42aacacb7 /dev-ml/js_of_ocaml/js_of_ocaml-3.0.0.ebuild
parentdev-util/patdiff: initial import (diff)
downloadgentoo-0dc5e83d174cd5271de5c6829ee987844a9eb886.tar.gz
gentoo-0dc5e83d174cd5271de5c6829ee987844a9eb886.tar.bz2
gentoo-0dc5e83d174cd5271de5c6829ee987844a9eb886.zip
dev-ml/js_of_ocaml: bump to 3.0.0 and update live ebuild
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-ml/js_of_ocaml/js_of_ocaml-3.0.0.ebuild')
-rw-r--r--dev-ml/js_of_ocaml/js_of_ocaml-3.0.0.ebuild75
1 files changed, 75 insertions, 0 deletions
diff --git a/dev-ml/js_of_ocaml/js_of_ocaml-3.0.0.ebuild b/dev-ml/js_of_ocaml/js_of_ocaml-3.0.0.ebuild
new file mode 100644
index 000000000000..3a44770cfb67
--- /dev/null
+++ b/dev-ml/js_of_ocaml/js_of_ocaml-3.0.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib eutils
+
+DESCRIPTION="A compiler from OCaml bytecode to javascript"
+HOMEPAGE="http://ocsigen.org/js_of_ocaml/"
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/ocsigen/js_of_ocaml"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/ocsigen/js_of_ocaml/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+IUSE="+ocamlopt camlp4 lwt doc +deriving +ppx +xml test"
+
+RDEPEND="
+ >=dev-lang/ocaml-3.12:=[ocamlopt?]
+
+ camlp4? ( dev-ml/camlp4:= )
+
+ dev-ml/cmdliner:=
+ dev-ml/cppo:=
+
+ lwt? ( >=dev-ml/lwt-2.4.4:= )
+
+ dev-ml/ocamlbuild:=
+
+ dev-ml/ocaml-migrate-parsetree:=
+ dev-ml/ppx_tools_versioned:=
+ dev-ml/uchar:=
+
+ ppx? ( dev-ml/ppx_tools:= dev-ml/ppx_deriving:= )
+
+ xml? ( >=dev-ml/tyxml-4:= dev-ml/reactiveData:= )
+"
+DEPEND="${RDEPEND}
+ dev-ml/jbuilder
+ dev-ml/opam
+ test? ( dev-util/patdiff )
+"
+REQUIRED_USE="xml? ( ppx )"
+
+src_compile() {
+ emake
+ use doc && emake doc
+}
+
+oinstall() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ --mandir="${ED}/usr/share/man" \
+ ${1}.install || die
+}
+
+src_install() {
+ use camlp4 && oinstall js_of_ocaml-camlp4
+ oinstall js_of_ocaml-compiler
+ use lwt && oinstall js_of_ocaml-lwt
+ oinstall js_of_ocaml-ocamlbuild
+ oinstall js_of_ocaml
+ use ppx && oinstall js_of_ocaml-ppx
+ use ppx && oinstall js_of_ocaml-toplevel
+ use xml && oinstall js_of_ocaml-tyxml
+}