summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-08-12 14:52:43 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-08-12 14:53:54 +0200
commitd01441512454fc516a18d2e19c6fb7b52d41d90a (patch)
treef10285345c48f800f8fff11b07ecdce98eb5f3cb /dev-ml/lablgtk/lablgtk-2.18.5.ebuild
parentdev-php/pecl-yaz: Version bump for php7-0 support (diff)
downloadgentoo-d01441512454fc516a18d2e19c6fb7b52d41d90a.tar.gz
gentoo-d01441512454fc516a18d2e19c6fb7b52d41d90a.tar.bz2
gentoo-d01441512454fc516a18d2e19c6fb7b52d41d90a.zip
dev-ml/lablgtk: bump to 2.18.5
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ml/lablgtk/lablgtk-2.18.5.ebuild')
-rw-r--r--dev-ml/lablgtk/lablgtk-2.18.5.ebuild83
1 files changed, 83 insertions, 0 deletions
diff --git a/dev-ml/lablgtk/lablgtk-2.18.5.ebuild b/dev-ml/lablgtk/lablgtk-2.18.5.ebuild
new file mode 100644
index 000000000000..3953b0f771f9
--- /dev/null
+++ b/dev-ml/lablgtk/lablgtk-2.18.5.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib findlib
+
+IUSE="debug examples glade gnomecanvas sourceview +ocamlopt opengl spell svg"
+
+DESCRIPTION="Objective CAML interface for Gtk+2"
+HOMEPAGE="http://lablgtk.forge.ocamlcore.org/"
+SRC_URI="https://forge.ocamlcore.org/frs/download.php/1627/${P}.tar.gz"
+LICENSE="LGPL-2.1-with-linking-exception examples? ( lablgtk-examples )"
+
+RDEPEND=">=x11-libs/gtk+-2.10:2
+ >=dev-lang/ocaml-3.10:=[ocamlopt?]
+ svg? ( >=gnome-base/librsvg-2.2:2 )
+ glade? ( >=gnome-base/libglade-2.0.1 )
+ gnomecanvas? ( >=gnome-base/libgnomecanvas-2.2 )
+ opengl? ( >=dev-ml/lablgl-0.98:=
+ >=x11-libs/gtkglarea-1.9:2 )
+ spell? ( app-text/gtkspell:2 )
+ sourceview? ( x11-libs/gtksourceview:2.0 )
+ dev-ml/camlp4:=
+ "
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+SLOT="2/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+
+src_configure() {
+ econf $(use_enable debug) \
+ $(use_with svg rsvg) \
+ $(use_with glade) \
+ --without-gnomeui \
+ --without-panel \
+ $(use_with opengl gl) \
+ $(use_with spell gtkspell) \
+ --without-gtksourceview \
+ $(use_with sourceview gtksourceview2) \
+ $(use_with gnomecanvas)
+}
+
+src_compile() {
+ emake -j1 all
+ if use ocamlopt; then
+ emake -j1 opt
+ fi
+}
+
+install_examples() {
+ insinto /usr/share/doc/${P}/examples
+ doins examples/*.ml examples/*.rgb examples/*.png examples/*.xpm
+
+ # Install examples for optional components
+ use gnomecanvas && insinto /usr/share/doc/${PF}/examples/canvas && doins examples/canvas/*.ml examples/canvas/*.png
+ use svg && insinto /usr/share/doc/${PF}/examples/rsvg && doins examples/rsvg/*.ml examples/rsvg/*.svg
+ use glade && insinto /usr/share/doc/${PF}/examples/glade && doins examples/glade/*.ml examples/glade/*.glade*
+ use sourceview && insinto /usr/share/doc/${PF}/examples/sourceview && doins examples/sourceview/*.ml examples/sourceview/*.lang
+ use opengl && insinto /usr/share/doc/${PF}/examples/GL && doins examples/GL/*.ml
+
+ docompress -x /usr/share/doc/${PF}/examples
+}
+
+src_install () {
+ findlib_src_preinst
+ export OCAMLPATH="${OCAMLFIND_DESTDIR}"
+ emake install DESTDIR="${D}"
+
+ rm -f "${ED}/usr/$(get_libdir)/ocaml/ld.conf"
+
+ dodoc CHANGES README CHANGES.API
+ use examples && install_examples
+}
+
+pkg_postinst () {
+ if use examples; then
+ elog "To run the examples you can use the lablgtk2 toplevel."
+ elog "e.g: lablgtk2 /usr/share/doc/${PF}/examples/testgtk.ml"
+ fi
+}