summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-02-21 11:17:25 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-02-21 11:17:51 +0100
commitf7aaa1bd599e40bfffcfb52f7ca5cb2a26250b51 (patch)
tree183649709055800d1649c07c54928efdf188f892 /dev-ml/lablgtk
parentdev-ml/lablgtk: Drop 2.18.5 and 2.18.8-r1, EAPI5-- (diff)
downloadgentoo-f7aaa1bd599e40bfffcfb52f7ca5cb2a26250b51.tar.gz
gentoo-f7aaa1bd599e40bfffcfb52f7ca5cb2a26250b51.tar.bz2
gentoo-f7aaa1bd599e40bfffcfb52f7ca5cb2a26250b51.zip
dev-ml/lablgtk: Revert "Drop 2.18.5 and 2.18.8-r1, EAPI5--"
Wrong branch pushed, sorry. This reverts commit e3b08dd2f60331b1a5c49a3f86a7e03fde75bebc. Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-ml/lablgtk')
-rw-r--r--dev-ml/lablgtk/Manifest2
-rw-r--r--dev-ml/lablgtk/lablgtk-2.18.5.ebuild79
-rw-r--r--dev-ml/lablgtk/lablgtk-2.18.8-r1.ebuild69
3 files changed, 150 insertions, 0 deletions
diff --git a/dev-ml/lablgtk/Manifest b/dev-ml/lablgtk/Manifest
index 7e47453703b4..7f5f09e07a7c 100644
--- a/dev-ml/lablgtk/Manifest
+++ b/dev-ml/lablgtk/Manifest
@@ -1,2 +1,4 @@
DIST lablgtk-2.18.10.tar.gz 1068504 BLAKE2B 8f82cd8b31c136420bfbbeaf78ec2d7913b7c5fc16abd485c508f8de3ab587173b0b5c798cdbe851254b48754929c1f0063cfc9e3c5e0663b7cdebc380ec0e8a SHA512 73705aaa80db433d11a28df5f6f5d10bd282e477e90916152a87e71865ccfcd7dfbdbe77350ecadf61ba2ccc7a188de1c68f1e6385e20c75f167969001e8418d
+DIST lablgtk-2.18.5.tar.gz 808005 BLAKE2B 279fd9f018948438b616a12ab60fca3019330504a79d8b76c58fa0a99a7b36df9bf78f57f0e60c4eea6f0bad60f94c06b26490518ec25a5a72c342e4b7c42501 SHA512 7b6ba1a4dfa82cc3bbc502082ff4fccc23cc06ee4f30d01a2e423f3f99e945a4befe450d230b5aa19c5b810e9f46f2838655099d49da2db7c8a2e52eac213024
+DIST lablgtk-2.18.8.tar.gz 855263 BLAKE2B 92aeadcfac666756e50ea573c7a2119cc13eab5c2f2e033fcdf92d5c33d597d64bf2e860ff181d958b4d8e9a3d4002b3eaabbd1da7580444fee91dafaba26289 SHA512 1510b8886dd55b82fbc96f333d84779f51a4794d13b0934569d13b1975ded9ec684855b9856f636fb302fd8ff2f118d0d5f3ffb2b8086d22cdad442e963868ae
DIST lablgtk3-3.1.1.tbz 854720 BLAKE2B e6a916151fe1ca0746c14c2a66cd178f3b0c051976815a1d13daf801002f16bc76d9f4cb15625353f0cfbdc16b0a218857d72c4e57125050bbcffe67f7096ad0 SHA512 193c340d9941680869eb90bc89f5b27cc5bdf294f4635081a9ba56a99fa2982266c4ee2eb5fd04d3a3f6150082800de5df786def8c72a276a779d843d914e9e3
diff --git a/dev-ml/lablgtk/lablgtk-2.18.5.ebuild b/dev-ml/lablgtk/lablgtk-2.18.5.ebuild
new file mode 100644
index 000000000000..9bef8aaa2b15
--- /dev/null
+++ b/dev-ml/lablgtk/lablgtk-2.18.5.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit multilib findlib
+
+IUSE="debug examples glade gnomecanvas sourceview +ocamlopt spell svg"
+
+DESCRIPTION="Objective CAML interface for Gtk+2"
+HOMEPAGE="http://lablgtk.forge.ocamlcore.org/"
+SRC_URI="https://forge.ocamlcore.org/frs/download.php/1627/${P}.tar.gz"
+LICENSE="LGPL-2.1-with-linking-exception examples? ( lablgtk-examples )"
+
+RDEPEND=">=x11-libs/gtk+-2.10:2
+ <dev-lang/ocaml-4.09:=[ocamlopt?]
+ svg? ( >=gnome-base/librsvg-2.2:2 )
+ glade? ( >=gnome-base/libglade-2.0.1 )
+ gnomecanvas? ( >=gnome-base/libgnomecanvas-2.2 )
+ spell? ( app-text/gtkspell:2 )
+ sourceview? ( x11-libs/gtksourceview:2.0 )
+ dev-ml/camlp4:=
+ "
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+SLOT="2/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+src_configure() {
+ econf $(use_enable debug) \
+ $(use_with svg rsvg) \
+ $(use_with glade) \
+ --without-gnomeui \
+ --without-panel \
+ --without-gl \
+ $(use_with spell gtkspell) \
+ --without-gtksourceview \
+ $(use_with sourceview gtksourceview2) \
+ $(use_with gnomecanvas)
+}
+
+src_compile() {
+ emake -j1 all
+ if use ocamlopt; then
+ emake -j1 opt
+ fi
+}
+
+install_examples() {
+ insinto /usr/share/doc/${P}/examples
+ doins examples/*.ml examples/*.rgb examples/*.png examples/*.xpm
+
+ # Install examples for optional components
+ use gnomecanvas && insinto /usr/share/doc/${PF}/examples/canvas && doins examples/canvas/*.ml examples/canvas/*.png
+ use svg && insinto /usr/share/doc/${PF}/examples/rsvg && doins examples/rsvg/*.ml examples/rsvg/*.svg
+ use glade && insinto /usr/share/doc/${PF}/examples/glade && doins examples/glade/*.ml examples/glade/*.glade*
+ use sourceview && insinto /usr/share/doc/${PF}/examples/sourceview && doins examples/sourceview/*.ml examples/sourceview/*.lang
+
+ docompress -x /usr/share/doc/${PF}/examples
+}
+
+src_install() {
+ findlib_src_preinst
+ export OCAMLPATH="${OCAMLFIND_DESTDIR}"
+ emake install DESTDIR="${D}"
+
+ rm -f "${ED}/usr/$(get_libdir)/ocaml/ld.conf"
+
+ dodoc CHANGES README CHANGES.API
+ use examples && install_examples
+}
+
+pkg_postinst() {
+ if use examples; then
+ elog "To run the examples you can use the lablgtk2 toplevel."
+ elog "e.g: lablgtk2 /usr/share/doc/${PF}/examples/testgtk.ml"
+ fi
+}
diff --git a/dev-ml/lablgtk/lablgtk-2.18.8-r1.ebuild b/dev-ml/lablgtk/lablgtk-2.18.8-r1.ebuild
new file mode 100644
index 000000000000..6bbe47119f84
--- /dev/null
+++ b/dev-ml/lablgtk/lablgtk-2.18.8-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Objective CAML interface for Gtk+2"
+HOMEPAGE="http://lablgtk.forge.ocamlcore.org"
+SRC_URI="https://github.com/garrigue/lablgtk/releases/download/lablgtk2188/${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception examples? ( lablgtk-examples )"
+SLOT="2/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug examples glade gnomecanvas +ocamlopt sourceview spell svg"
+
+DEPEND="dev-lang/ocaml:=[ocamlopt?]
+ dev-ml/camlp4:=
+ x11-libs/gtk+:2
+ glade? ( gnome-base/libglade )
+ gnomecanvas? ( gnome-base/libgnomecanvas )
+ sourceview? ( x11-libs/gtksourceview:2.0 )
+ spell? ( app-text/gtkspell:2 )
+ svg? ( gnome-base/librsvg:2 )"
+RDEPEND="${DEPEND}"
+BDEPEND="dev-ml/findlib
+ virtual/pkgconfig"
+
+DOCS=( CHANGES README CHANGES.API )
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ $(use_with svg rsvg)
+ $(use_with glade)
+ --without-gnomeui
+ --without-panel
+ # relies on EOL gtkglarea
+ --without-gl
+ $(use_with spell gtkspell)
+ --without-gtksourceview
+ $(use_with sourceview gtksourceview2)
+ $(use_with gnomecanvas)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ # parallel build crashes
+ emake -j1 all
+ if use ocamlopt; then
+ emake -j1 opt
+ fi
+}
+
+src_install() {
+ local destdir="$(ocamlfind printconf destdir || die)"
+ dodir "${destdir}/stublibs"
+ export OCAMLFIND_DESTDIR=${ED}"${destdir}"
+ export OCAMLPATH="${ED}${destdir}"
+ export OCAMLFIND_LDCONF=ignore
+
+ default
+ rm "${ED}/usr/$(get_libdir)/ocaml/ld.conf" || die
+
+ if use examples; then
+ dodoc -r examples/
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}