summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-09 21:19:08 +0000
committerSam James <sam@gentoo.org>2021-06-09 21:19:08 +0000
commit0dc9e7b0edf4df32f9fbafdf698382a02a0be1ad (patch)
tree1428f9d835363a042ac03ca782e90de696c27e63 /dev-ml/labltk
parentdev-db/mariadb: Stabilize 10.5.10 arm64, #789240 (diff)
downloadgentoo-0dc9e7b0edf4df32f9fbafdf698382a02a0be1ad.tar.gz
gentoo-0dc9e7b0edf4df32f9fbafdf698382a02a0be1ad.tar.bz2
gentoo-0dc9e7b0edf4df32f9fbafdf698382a02a0be1ad.zip
dev-ml/labltk: add 8.06.10
Closes: https://bugs.gentoo.org/794964 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml/labltk')
-rw-r--r--dev-ml/labltk/Manifest1
-rw-r--r--dev-ml/labltk/labltk-8.06.10.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-ml/labltk/Manifest b/dev-ml/labltk/Manifest
index 57ec70566679..584d70ab00ea 100644
--- a/dev-ml/labltk/Manifest
+++ b/dev-ml/labltk/Manifest
@@ -1,2 +1,3 @@
+DIST labltk-8.06.10.tar.gz 371871 BLAKE2B da67b13aa0a0c179c2fcefe6b03f68225b6e886a1233de77b9749be32b8efc845cac60244f9a8494241c8c77c7d6991786280c274becb70f5527ad891c3aac69 SHA512 ef797d21adac48ca5ed35d95ad05fee26f9b6c99b0510909f6087abb9580b8efd219ca65b1efddb170b5409567d83eaaac0473898f5f4db3e15ae4f39df364c8
DIST labltk-8.06.7.tar.gz 370870 BLAKE2B 2d836c824d9adbd4f03d0e7e81faa51669837eecb4f94f6c89c657966774fe7d6ed928459be3ccca7fd3e7cf67a54ee63f7d2d08dcc8b7e853f5ad64769b33a2 SHA512 3c7352d14bc337adfb1939e72bd2658bb5e60b463f10f3748779084d1b7a6e6225028c775b548e355d69984a8944b91580fa978ff904b20b8b762ba9046f5e7d
DIST labltk-8.06.9.tar.gz 371504 BLAKE2B 587ff01da120501f85f6d9921e46275858f1e1ce730eef205f9e7d7c64f6d3c0ea701cf832fdb8eb0746e1f0cff1151bccb077641740fb18811473b1553e2940 SHA512 fd6defa302d919f229394c486dcefab110b144534525a87082a27d2cab29c0af4ece3da821098fea25416850ad857f7af979d48790330d62dfb8d8db8f2bf6ca
diff --git a/dev-ml/labltk/labltk-8.06.10.ebuild b/dev-ml/labltk/labltk-8.06.10.ebuild
new file mode 100644
index 000000000000..10d78bc548ad
--- /dev/null
+++ b/dev-ml/labltk/labltk-8.06.10.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit findlib
+
+DESCRIPTION="OCaml interface to the Tcl/Tk GUI framework"
+HOMEPAGE="https://garrigue.github.io/labltk/"
+SRC_URI="https://github.com/garrigue/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="QPL-1.0 LGPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+ocamlopt X"
+
+RDEPEND="dev-lang/tk:=
+ >=dev-lang/ocaml-4.11:=[ocamlopt?,X(+)?]"
+DEPEND="${RDEPEND}
+ dev-ml/findlib
+"
+
+PATCHES=(
+ "${FILESDIR}/findlib.patch"
+)
+
+src_configure() {
+ ./configure --use-findlib --verbose $(usex X "--tk-x11" "--tk-no-x11") || die "configure failed!"
+}
+
+src_compile() {
+ emake -j1
+ use ocamlopt && emake -j1 opt
+}
+
+src_install() {
+ findlib_src_preinst
+ dodir /usr/bin
+ emake \
+ INSTALLDIR="${D}/$(ocamlc -where)/labltk" \
+ INSTALLBINDIR="${ED}/usr/bin/" \
+ install
+ dodoc Changes README.mlTk
+}