summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-03-22 16:53:08 +0100
committerMichał Górny <mgorny@gentoo.org>2019-03-22 18:07:22 +0100
commit16a9ff90261424f5b3f0c1b8eb4966efa6348793 (patch)
treef0632bbd20e83cac8dd68177b92789fdbe77e11e /dev-ml/llvm-ocaml
parentsys-devel/llvm: WebAssembly is no longer experimental in 8.0+ (diff)
downloadgentoo-16a9ff90261424f5b3f0c1b8eb4966efa6348793.tar.gz
gentoo-16a9ff90261424f5b3f0c1b8eb4966efa6348793.tar.bz2
gentoo-16a9ff90261424f5b3f0c1b8eb4966efa6348793.zip
dev-ml/llvm-ocaml: WebAssembly is no longer experimental in 8.0+
Reported-by: Matthew Smith <matt@offtopica.uk> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-ml/llvm-ocaml')
-rw-r--r--dev-ml/llvm-ocaml/llvm-ocaml-8.0.0.ebuild2
-rw-r--r--dev-ml/llvm-ocaml/llvm-ocaml-8.0.9999.ebuild2
-rw-r--r--dev-ml/llvm-ocaml/llvm-ocaml-9999.ebuild4
3 files changed, 4 insertions, 4 deletions
diff --git a/dev-ml/llvm-ocaml/llvm-ocaml-8.0.0.ebuild b/dev-ml/llvm-ocaml/llvm-ocaml-8.0.0.ebuild
index 844cf32241cb..f083d7d40b80 100644
--- a/dev-ml/llvm-ocaml/llvm-ocaml-8.0.0.ebuild
+++ b/dev-ml/llvm-ocaml/llvm-ocaml-8.0.0.ebuild
@@ -17,7 +17,7 @@ SRC_URI="https://releases.llvm.org/${PV/_//}/${MY_P}.tar.xz"
# Keep in sync with sys-devel/llvm
ALL_LLVM_TARGETS=( AArch64 AMDGPU ARM BPF Hexagon Lanai Mips MSP430
- NVPTX PowerPC Sparc SystemZ X86 XCore )
+ NVPTX PowerPC Sparc SystemZ WebAssembly X86 XCore )
ALL_LLVM_TARGETS=( "${ALL_LLVM_TARGETS[@]/#/llvm_targets_}" )
LLVM_TARGET_USEDEPS=${ALL_LLVM_TARGETS[@]/%/?}
diff --git a/dev-ml/llvm-ocaml/llvm-ocaml-8.0.9999.ebuild b/dev-ml/llvm-ocaml/llvm-ocaml-8.0.9999.ebuild
index 1857f99418c1..1d5a88b0a176 100644
--- a/dev-ml/llvm-ocaml/llvm-ocaml-8.0.9999.ebuild
+++ b/dev-ml/llvm-ocaml/llvm-ocaml-8.0.9999.ebuild
@@ -19,7 +19,7 @@ EGIT_BRANCH="release_80"
# Keep in sync with sys-devel/llvm
ALL_LLVM_TARGETS=( AArch64 AMDGPU ARM BPF Hexagon Lanai Mips MSP430
- NVPTX PowerPC Sparc SystemZ X86 XCore )
+ NVPTX PowerPC Sparc SystemZ WebAssembly X86 XCore )
ALL_LLVM_TARGETS=( "${ALL_LLVM_TARGETS[@]/#/llvm_targets_}" )
LLVM_TARGET_USEDEPS=${ALL_LLVM_TARGETS[@]/%/?}
diff --git a/dev-ml/llvm-ocaml/llvm-ocaml-9999.ebuild b/dev-ml/llvm-ocaml/llvm-ocaml-9999.ebuild
index 6fa322a6fd10..1f5f6bf010e1 100644
--- a/dev-ml/llvm-ocaml/llvm-ocaml-9999.ebuild
+++ b/dev-ml/llvm-ocaml/llvm-ocaml-9999.ebuild
@@ -17,9 +17,9 @@ EGIT_REPO_URI="https://git.llvm.org/git/llvm.git
https://github.com/llvm-mirror/llvm.git"
# Keep in sync with sys-devel/llvm
-ALL_LLVM_EXPERIMENTAL_TARGETS=( AVR Nios2 RISCV WebAssembly )
+ALL_LLVM_EXPERIMENTAL_TARGETS=( AVR Nios2 RISCV )
ALL_LLVM_TARGETS=( AArch64 AMDGPU ARM BPF Hexagon Lanai Mips MSP430
- NVPTX PowerPC Sparc SystemZ X86 XCore
+ NVPTX PowerPC Sparc SystemZ WebAssembly X86 XCore
"${ALL_LLVM_EXPERIMENTAL_TARGETS[@]}" )
ALL_LLVM_TARGETS=( "${ALL_LLVM_TARGETS[@]/#/llvm_targets_}" )
LLVM_TARGET_USEDEPS=${ALL_LLVM_TARGETS[@]/%/?}