summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-29 11:35:14 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-29 11:35:14 +0100
commit75f89477e6964badf366c72e349723ac945fc028 (patch)
tree2c69ead65fe54df04fe0b918978895376630bf61 /dev-ml/llvm-ocaml
parentdev-ml/llvm-ocaml: Fix missing conditions around deps (diff)
downloadgentoo-75f89477e6964badf366c72e349723ac945fc028.tar.gz
gentoo-75f89477e6964badf366c72e349723ac945fc028.tar.bz2
gentoo-75f89477e6964badf366c72e349723ac945fc028.zip
dev-ml/llvm-ocaml: Fix old versions too
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-ml/llvm-ocaml')
-rw-r--r--dev-ml/llvm-ocaml/llvm-ocaml-10.0.1.ebuild2
-rw-r--r--dev-ml/llvm-ocaml/llvm-ocaml-11.0.0.ebuild2
-rw-r--r--dev-ml/llvm-ocaml/llvm-ocaml-9.0.1.ebuild2
3 files changed, 3 insertions, 3 deletions
diff --git a/dev-ml/llvm-ocaml/llvm-ocaml-10.0.1.ebuild b/dev-ml/llvm-ocaml/llvm-ocaml-10.0.1.ebuild
index 17ad0324ab8e..c9f95c843aa6 100644
--- a/dev-ml/llvm-ocaml/llvm-ocaml-10.0.1.ebuild
+++ b/dev-ml/llvm-ocaml/llvm-ocaml-10.0.1.ebuild
@@ -32,7 +32,7 @@ RDEPEND="
!sys-devel/llvm[ocaml(-)]"
for x in "${ALL_LLVM_TARGETS[@]}"; do
RDEPEND+="
- ~sys-devel/llvm-${PV}[${x}]"
+ ${x}? ( ~sys-devel/llvm-${PV}[${x}] )"
done
unset x
diff --git a/dev-ml/llvm-ocaml/llvm-ocaml-11.0.0.ebuild b/dev-ml/llvm-ocaml/llvm-ocaml-11.0.0.ebuild
index 1cc3103d9d2f..425c6b247335 100644
--- a/dev-ml/llvm-ocaml/llvm-ocaml-11.0.0.ebuild
+++ b/dev-ml/llvm-ocaml/llvm-ocaml-11.0.0.ebuild
@@ -32,7 +32,7 @@ RDEPEND="
!sys-devel/llvm[ocaml(-)]"
for x in "${ALL_LLVM_TARGETS[@]}"; do
RDEPEND+="
- ~sys-devel/llvm-${PV}[${x}]"
+ ${x}? ( ~sys-devel/llvm-${PV}[${x}] )"
done
unset x
diff --git a/dev-ml/llvm-ocaml/llvm-ocaml-9.0.1.ebuild b/dev-ml/llvm-ocaml/llvm-ocaml-9.0.1.ebuild
index d2b0fe4d1212..f6d102ad555c 100644
--- a/dev-ml/llvm-ocaml/llvm-ocaml-9.0.1.ebuild
+++ b/dev-ml/llvm-ocaml/llvm-ocaml-9.0.1.ebuild
@@ -30,7 +30,7 @@ RDEPEND="
!sys-devel/llvm[ocaml(-)]"
for x in "${ALL_LLVM_TARGETS[@]}"; do
RDEPEND+="
- ~sys-devel/llvm-${PV}[${x}]"
+ ${x}? ( ~sys-devel/llvm-${PV}[${x}] )"
done
unset x