summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-01 18:37:38 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-03 12:46:10 +0100
commit93c15cd3f35765500aed9e9061a83dbe63ec11a7 (patch)
tree9bf30c025b9b7a661366c2f1f3a26d3998601f36 /dev-ml/llvm-ocaml
parentsys-devel/llvm: Port 9+ to llvm.org.eclass (diff)
downloadgentoo-93c15cd3f35765500aed9e9061a83dbe63ec11a7.tar.gz
gentoo-93c15cd3f35765500aed9e9061a83dbe63ec11a7.tar.bz2
gentoo-93c15cd3f35765500aed9e9061a83dbe63ec11a7.zip
dev-ml/llvm-ocaml: Port 9+ to llvm.org.eclass
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-ml/llvm-ocaml')
-rw-r--r--dev-ml/llvm-ocaml/llvm-ocaml-10.0.0.9999.ebuild12
-rw-r--r--dev-ml/llvm-ocaml/llvm-ocaml-9.0.0.ebuild7
-rw-r--r--dev-ml/llvm-ocaml/llvm-ocaml-9.0.1.9999.ebuild13
3 files changed, 9 insertions, 23 deletions
diff --git a/dev-ml/llvm-ocaml/llvm-ocaml-10.0.0.9999.ebuild b/dev-ml/llvm-ocaml/llvm-ocaml-10.0.0.9999.ebuild
index 986eb0186f7c..4b0cb21a9496 100644
--- a/dev-ml/llvm-ocaml/llvm-ocaml-10.0.0.9999.ebuild
+++ b/dev-ml/llvm-ocaml/llvm-ocaml-10.0.0.9999.ebuild
@@ -4,13 +4,12 @@
EAPI=7
PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
-inherit cmake-utils git-r3 llvm multiprocessing python-any-r1
+inherit cmake-utils llvm llvm.org multiprocessing python-any-r1
DESCRIPTION="OCaml bindings for LLVM"
HOMEPAGE="https://llvm.org/"
-SRC_URI=""
-EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
-S=${WORKDIR}/${P}/llvm
+LLVM_COMPONENTS=( llvm )
+llvm.org_set_globals
# Keep in sync with sys-devel/llvm
ALL_LLVM_EXPERIMENTAL_TARGETS=( ARC AVR )
@@ -49,11 +48,6 @@ pkg_setup() {
python-any-r1_pkg_setup
}
-src_unpack() {
- git-r3_fetch
- git-r3_checkout '' '' '' llvm
-}
-
src_prepare() {
# Python is needed to run tests using lit
python_setup
diff --git a/dev-ml/llvm-ocaml/llvm-ocaml-9.0.0.ebuild b/dev-ml/llvm-ocaml/llvm-ocaml-9.0.0.ebuild
index bca23552f288..79b9b550b232 100644
--- a/dev-ml/llvm-ocaml/llvm-ocaml-9.0.0.ebuild
+++ b/dev-ml/llvm-ocaml/llvm-ocaml-9.0.0.ebuild
@@ -4,13 +4,12 @@
EAPI=7
PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
-inherit cmake-utils llvm multiprocessing python-any-r1
+inherit cmake-utils llvm llvm.org multiprocessing python-any-r1
-MY_P=llvm-${PV/_/}.src
DESCRIPTION="OCaml bindings for LLVM"
HOMEPAGE="https://llvm.org/"
-SRC_URI="https://releases.llvm.org/${PV}/${MY_P}.tar.xz"
-S=${WORKDIR}/${MY_P}
+LLVM_COMPONENTS=( llvm )
+llvm.org_set_globals
# Keep in sync with sys-devel/llvm
ALL_LLVM_TARGETS=( AArch64 AMDGPU ARM BPF Hexagon Lanai Mips MSP430
diff --git a/dev-ml/llvm-ocaml/llvm-ocaml-9.0.1.9999.ebuild b/dev-ml/llvm-ocaml/llvm-ocaml-9.0.1.9999.ebuild
index 5d4cd53080e3..8084c82be3e6 100644
--- a/dev-ml/llvm-ocaml/llvm-ocaml-9.0.1.9999.ebuild
+++ b/dev-ml/llvm-ocaml/llvm-ocaml-9.0.1.9999.ebuild
@@ -4,14 +4,12 @@
EAPI=7
PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
-inherit cmake-utils git-r3 llvm multiprocessing python-any-r1
+inherit cmake-utils llvm llvm.org multiprocessing python-any-r1
DESCRIPTION="OCaml bindings for LLVM"
HOMEPAGE="https://llvm.org/"
-SRC_URI=""
-EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
-EGIT_BRANCH="release/9.x"
-S=${WORKDIR}/${P}/llvm
+LLVM_COMPONENTS=( llvm )
+llvm.org_set_globals
# Keep in sync with sys-devel/llvm
ALL_LLVM_TARGETS=( AArch64 AMDGPU ARM BPF Hexagon Lanai Mips MSP430
@@ -48,11 +46,6 @@ pkg_setup() {
python-any-r1_pkg_setup
}
-src_unpack() {
- git-r3_fetch
- git-r3_checkout '' '' '' llvm
-}
-
src_prepare() {
# Python is needed to run tests using lit
python_setup