summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-12-07 20:30:47 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-12-07 20:31:40 +0100
commit4c3253bc560bd84aec50fb691bf9410193d375ca (patch)
treef4066c4768bde32a8b1099e3a0fae91cb559a01d /dev-ml/lwt
parentdev-ml/pgocaml: enable camlp4 by default (diff)
downloadgentoo-4c3253bc560bd84aec50fb691bf9410193d375ca.tar.gz
gentoo-4c3253bc560bd84aec50fb691bf9410193d375ca.tar.bz2
gentoo-4c3253bc560bd84aec50fb691bf9410193d375ca.zip
dev-ml/lwt: bump to 2.6.0
Package-Manager: portage-2.3.3
Diffstat (limited to 'dev-ml/lwt')
-rw-r--r--dev-ml/lwt/Manifest1
-rw-r--r--dev-ml/lwt/lwt-2.6.0.ebuild42
-rw-r--r--dev-ml/lwt/metadata.xml1
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-ml/lwt/Manifest b/dev-ml/lwt/Manifest
index 626c2d055375..7569ba15ca14 100644
--- a/dev-ml/lwt/Manifest
+++ b/dev-ml/lwt/Manifest
@@ -1,2 +1,3 @@
DIST lwt-2.4.3.tar.gz 504000 SHA256 efee23937750290d6dee96eed6c0bbdb19817d5be6eefcba61ac5031fac10107 SHA512 725d50a096a43294d49ae2322fdc985c301ce6a8ff5c956925225d7977e787ccb446e36a9db5fdbb50f284b9f1a3a12a52d1aa44d4400feecb59f6f938ed00ad WHIRLPOOL c5999e950008902600b43bf39f174ed0bc2cb3f6dce983d885416969a3bb98170ec8b74c8f5829459c3c96d160e5b4c8491b7057e7efeac035a46c9846ff7764
DIST lwt-2.5.2.tar.gz 268168 SHA256 b319514cf51656780a8f609a63ead08d3052a442546b218530ce146d37bf6331 SHA512 83c7a9d9798fe12e0bdd618e7f69ac357065a9b26e2abb644240c420cb1d507a3b558549b2f82ecc9c3fbc9ca5952e8d7cb32b6832713bfb6fffcb58975d5449 WHIRLPOOL f0482836988a248b691c332ef7acbeb5121226582cb8ef1e0b301719d35e25fd5d08e6b7b9e9ab02081b4d734ddc399251a31b66a26859542a4484342e517257
+DIST lwt-2.6.0.tar.gz 288385 SHA256 bf7ff0d1c3aa8230f00f55cac149cd335a1a1183b4661c9b098ba8a2d0037cbd SHA512 a30accd39941b421a8afd908129c799bcd178caeabbf36f8a67e07da1e088b4a163a0916738bb11b301972e42800aaf1c194b7eed4d67eb15ea69d04f7cb8abc WHIRLPOOL 963b45a7affa39ceeef209100d293db189fd8bfc21b8c385f92fbbcdeced9df185fca29119af69e72927e628012cff7dd9632067150f4baeeeca967f2616ad74
diff --git a/dev-ml/lwt/lwt-2.6.0.ebuild b/dev-ml/lwt/lwt-2.6.0.ebuild
new file mode 100644
index 000000000000..c92324ced9b6
--- /dev/null
+++ b/dev-ml/lwt/lwt-2.6.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_TESTS=1
+# fails to build
+#OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="Cooperative light-weight thread library for OCaml"
+SRC_URI="https://github.com/ocsigen/lwt/archive/${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="http://ocsigen.org/lwt"
+
+IUSE="+camlp4 gtk +ppx +react +ssl"
+
+DEPEND="react? ( >=dev-ml/react-1.2:= )
+ dev-libs/libev
+ ssl? ( >=dev-ml/ocaml-ssl-0.4.0:= )
+ gtk? ( dev-ml/lablgtk:= dev-libs/glib:2 )
+ ppx? ( dev-ml/ppx_tools:= )
+ camlp4? ( dev-ml/camlp4:= )"
+
+RDEPEND="${DEPEND}
+ !<www-servers/ocsigen-1.1"
+
+SLOT="0/${PV}"
+LICENSE="LGPL-2.1-with-linking-exception"
+KEYWORDS="~amd64 ~x86-fbsd"
+
+DOCS=( "CHANGES" "README.md" )
+
+src_configure() {
+ oasis_configure_opts="$(use_enable gtk glib)
+ $(use_enable react)
+ $(use_enable ssl)
+ $(use_enable camlp4)
+ $(use_enable ppx)" \
+ oasis_src_configure
+}
diff --git a/dev-ml/lwt/metadata.xml b/dev-ml/lwt/metadata.xml
index c91fb5ffa21a..5316207ba222 100644
--- a/dev-ml/lwt/metadata.xml
+++ b/dev-ml/lwt/metadata.xml
@@ -10,6 +10,7 @@
<name>Gentoo ML Project</name>
</maintainer>
<use>
+ <flag name="camlp4">Enable camlp4 syntax extension</flag>
<flag name="ppx">Enables the ppx syntax extension</flag>
<flag name="react">Enables support for <pkg>dev-ml/react</pkg>: Functional reactive programming (signals, events, etc.).</flag>
</use>