summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-03 12:22:23 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-03 12:22:48 +0200
commit461ea5502f9d20518d38584fd1e9f62dcbc66557 (patch)
treec384ecb3f6b22dca4fc8a9eb90e90de460bedd08 /dev-ml/merlin/merlin-2.5.3.ebuild
parentnet-misc/plowshare: drop old (diff)
downloadgentoo-461ea5502f9d20518d38584fd1e9f62dcbc66557.tar.gz
gentoo-461ea5502f9d20518d38584fd1e9f62dcbc66557.tar.bz2
gentoo-461ea5502f9d20518d38584fd1e9f62dcbc66557.zip
dev-ml/merlin: Initial import
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ml/merlin/merlin-2.5.3.ebuild')
-rw-r--r--dev-ml/merlin/merlin-2.5.3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ml/merlin/merlin-2.5.3.ebuild b/dev-ml/merlin/merlin-2.5.3.ebuild
new file mode 100644
index 000000000000..609f9767e4cc
--- /dev/null
+++ b/dev-ml/merlin/merlin-2.5.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit findlib vim-plugin
+
+DESCRIPTION="Context sensitive completion for OCaml in Vim and Emacs"
+HOMEPAGE="https://github.com/ocaml/merlin"
+SRC_URI="https://github.com/ocaml/merlin/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-lang/ocaml:=
+ dev-ml/yojson:=
+"
+RDEPEND="${DEPEND}
+ || ( app-editors/vim[python] app-editors/gvim[python] )"
+
+src_configure() {
+ ./configure \
+ --prefix "${EPREFIX}/usr" \
+ --vimdir "${EPREFIX}//usr/share/vim/vimfiles" \
+ || die
+}
+
+src_install() {
+ default
+}