summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-06-15 10:13:31 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-06-15 10:49:42 +0200
commit8bedda265f99963762de244d1e3d77c9a6e07c84 (patch)
tree178fc0a29978bcbebe60d1142b5dcce457cba40f /dev-ml/merlin/merlin-2.5.5.ebuild
parentdev-ml/markup: bump to 0.7.5 (diff)
downloadgentoo-8bedda265f99963762de244d1e3d77c9a6e07c84.tar.gz
gentoo-8bedda265f99963762de244d1e3d77c9a6e07c84.tar.bz2
gentoo-8bedda265f99963762de244d1e3d77c9a6e07c84.zip
dev-ml/merlin: bump to 2.5.5
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-ml/merlin/merlin-2.5.5.ebuild')
-rw-r--r--dev-ml/merlin/merlin-2.5.5.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ml/merlin/merlin-2.5.5.ebuild b/dev-ml/merlin/merlin-2.5.5.ebuild
new file mode 100644
index 000000000000..609f9767e4cc
--- /dev/null
+++ b/dev-ml/merlin/merlin-2.5.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit findlib vim-plugin
+
+DESCRIPTION="Context sensitive completion for OCaml in Vim and Emacs"
+HOMEPAGE="https://github.com/ocaml/merlin"
+SRC_URI="https://github.com/ocaml/merlin/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-lang/ocaml:=
+ dev-ml/yojson:=
+"
+RDEPEND="${DEPEND}
+ || ( app-editors/vim[python] app-editors/gvim[python] )"
+
+src_configure() {
+ ./configure \
+ --prefix "${EPREFIX}/usr" \
+ --vimdir "${EPREFIX}//usr/share/vim/vimfiles" \
+ || die
+}
+
+src_install() {
+ default
+}