summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-10-04 09:46:57 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-10-04 10:01:43 +0200
commit24afb16a1858a31795681bf7f5750b3cb6fde78b (patch)
tree7b392f4cfc0c6e505282139750a5d3154c63928f /dev-ml/merlin/merlin-3.0.3.ebuild
parentdev-ml/ocamlmod: bump to 0.0.9 (diff)
downloadgentoo-24afb16a1858a31795681bf7f5750b3cb6fde78b.tar.gz
gentoo-24afb16a1858a31795681bf7f5750b3cb6fde78b.tar.bz2
gentoo-24afb16a1858a31795681bf7f5750b3cb6fde78b.zip
dev-ml/merlin: bump to 3.0.3
Package-Manager: Portage-2.3.11, Repoman-2.3.3
Diffstat (limited to 'dev-ml/merlin/merlin-3.0.3.ebuild')
-rw-r--r--dev-ml/merlin/merlin-3.0.3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ml/merlin/merlin-3.0.3.ebuild b/dev-ml/merlin/merlin-3.0.3.ebuild
new file mode 100644
index 000000000000..609f9767e4cc
--- /dev/null
+++ b/dev-ml/merlin/merlin-3.0.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit findlib vim-plugin
+
+DESCRIPTION="Context sensitive completion for OCaml in Vim and Emacs"
+HOMEPAGE="https://github.com/ocaml/merlin"
+SRC_URI="https://github.com/ocaml/merlin/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-lang/ocaml:=
+ dev-ml/yojson:=
+"
+RDEPEND="${DEPEND}
+ || ( app-editors/vim[python] app-editors/gvim[python] )"
+
+src_configure() {
+ ./configure \
+ --prefix "${EPREFIX}/usr" \
+ --vimdir "${EPREFIX}//usr/share/vim/vimfiles" \
+ || die
+}
+
+src_install() {
+ default
+}