summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-07 02:38:34 +0100
committerSam James <sam@gentoo.org>2021-10-07 02:38:52 +0100
commit372049e39ab93af18ce0e72e884ee2ca5ea1b5a9 (patch)
tree7882014b316b5b9789fef2d9aea475fdc56527a4 /dev-ml/num
parentapp-editors/nano: Stabilize 5.8-r2 ppc64, #816669 (diff)
downloadgentoo-372049e39ab93af18ce0e72e884ee2ca5ea1b5a9.tar.gz
gentoo-372049e39ab93af18ce0e72e884ee2ca5ea1b5a9.tar.bz2
gentoo-372049e39ab93af18ce0e72e884ee2ca5ea1b5a9.zip
dev-ml/num: fix collision with newer findlib
Closes: https://bugs.gentoo.org/803275 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml/num')
-rw-r--r--dev-ml/num/num-1.4-r2.ebuild (renamed from dev-ml/num/num-1.4-r1.ebuild)9
1 files changed, 7 insertions, 2 deletions
diff --git a/dev-ml/num/num-1.4-r1.ebuild b/dev-ml/num/num-1.4-r2.ebuild
index cf5b56b7a6d8..cf3d3b3bc4c9 100644
--- a/dev-ml/num/num-1.4-r1.ebuild
+++ b/dev-ml/num/num-1.4-r2.ebuild
@@ -16,6 +16,7 @@ KEYWORDS="amd64 arm arm64 ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-
IUSE="+ocamlopt"
RDEPEND="dev-lang/ocaml:=[ocamlopt?]"
+DEPEND="dev-ml/findlib:="
src_compile() {
emake CFLAGS="${CFLAGS}" NATDYNLINK="$(usex ocamlopt true false)"
@@ -27,6 +28,10 @@ src_test() {
}
src_install() {
- findlib_src_preinst
- OCAMLPATH="${OCAMLFIND_DESTDIR}" emake install DESTDIR="${D}" NATDYNLINK="$(usex ocamlopt true false)"
+ findlib_src_install
+
+ if has_version ">=dev-ml/findlib-1.9" ; then
+ # See bug #803275
+ rm "${ED}/usr/$(get_libdir)/ocaml/num-top/META" || die
+ fi
}