summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-01-12 20:03:24 +0100
committerAlfredo Tupone <tupone@gentoo.org>2022-01-12 20:03:24 +0100
commitdf63ec0cfb7adccbc4e0e70b00a4a989ec474035 (patch)
tree24dcde6ad395ef22e8fc5e1dfb7825f1a9e2b7aa /dev-ml/num
parentwww-client/chromium: dev channel bump to 99.0.4818.0 (diff)
downloadgentoo-df63ec0cfb7adccbc4e0e70b00a4a989ec474035.tar.gz
gentoo-df63ec0cfb7adccbc4e0e70b00a4a989ec474035.tar.bz2
gentoo-df63ec0cfb7adccbc4e0e70b00a4a989ec474035.zip
dev-ml/num: respect ocamlopt
Closes: https://bugs.gentoo.org/822321 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/num')
-rw-r--r--dev-ml/num/files/num-1.4-ocamlopt.patch15
-rw-r--r--dev-ml/num/num-1.4-r3.ebuild2
2 files changed, 17 insertions, 0 deletions
diff --git a/dev-ml/num/files/num-1.4-ocamlopt.patch b/dev-ml/num/files/num-1.4-ocamlopt.patch
new file mode 100644
index 000000000000..90699b99474c
--- /dev/null
+++ b/dev-ml/num/files/num-1.4-ocamlopt.patch
@@ -0,0 +1,15 @@
+--- a/src/Makefile 2022-01-12 19:58:54.655901110 +0100
++++ b/src/Makefile 2022-01-12 19:59:25.446339664 +0100
+@@ -33,11 +33,10 @@
+
+ all:: libnums.$(A) nums.cma
+
++ifeq "$(NATDYNLINK)" "true"
+ ifneq "$(ARCH)" "none"
+ all:: nums.cmxa
+ endif
+-
+-ifeq "$(NATDYNLINK)" "true"
+ all:: nums.cmxs
+ endif
+
diff --git a/dev-ml/num/num-1.4-r3.ebuild b/dev-ml/num/num-1.4-r3.ebuild
index 4b0101e0e90f..6440704457e1 100644
--- a/dev-ml/num/num-1.4-r3.ebuild
+++ b/dev-ml/num/num-1.4-r3.ebuild
@@ -19,6 +19,8 @@ RDEPEND="dev-lang/ocaml:=[ocamlopt?]"
BDEPEND="${RDEPEND}"
DEPEND="dev-ml/findlib:=[ocamlopt?]"
+PATCHES=( "${FILESDIR}"/${P}-ocamlopt.patch )
+
src_compile() {
emake CFLAGS="${CFLAGS}" NATDYNLINK="$(usex ocamlopt true false)"
}