summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-05-23 15:59:36 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-05-24 13:07:15 +0200
commita014a2a29b5e0e38e12d077038ce6c032846d12f (patch)
tree9ae6c5fd78c62b34d756e5ad3f6623de5765545e /dev-ml/oasis
parentdev-ml/octavius: Bump to 1.1.0 (diff)
downloadgentoo-a014a2a29b5e0e38e12d077038ce6c032846d12f.tar.gz
gentoo-a014a2a29b5e0e38e12d077038ce6c032846d12f.tar.bz2
gentoo-a014a2a29b5e0e38e12d077038ce6c032846d12f.zip
dev-ml/oasis: Bump to 0.4.10
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-ml/oasis')
-rw-r--r--dev-ml/oasis/Manifest1
-rw-r--r--dev-ml/oasis/oasis-0.4.10.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-ml/oasis/Manifest b/dev-ml/oasis/Manifest
index 4d65e92b6837..4c6b69ab2dd8 100644
--- a/dev-ml/oasis/Manifest
+++ b/dev-ml/oasis/Manifest
@@ -1 +1,2 @@
+DIST oasis-0.4.10.tar.gz 394732 SHA256 1cd9071403a2edb79dacbca8a96bdc6be754e786e1a45e69d9326fb6ee00508d SHA512 c173a3a774d13a7cb21ddb44f89dadef210d331ab5f3a1e7ff1705e815572f70e22815736cc3f3788b6d8f784c21a309b45c5bf5e984e583b31931847bf107fd WHIRLPOOL 22f30c9150ee38096d4de6dadb52a41f58d5d7bed5fd71cd83de2e641b16b2329e47156d6b587b451fbb08ddfcc01eb69bca4e846029d5ebf0637f8634492b55
DIST oasis-0.4.8.tar.gz 389565 SHA256 1e535de19fce623cc0019d2bbc4b158ac47e10b0165620e2ea459b1b0fdbc7d2 SHA512 e0baf0f048647c25eac5472db0d2a22d0fcaf85fe61ebd88ec5a101c20d4916ecfa9d10fae069ba4479abb22b90c44f18312b9252727a8c7c7de4aa2d8d72663 WHIRLPOOL db9deb3ddacf19ad1728e5b7d2f8e5f3785bb3a462bb64d6dbf82784c0335c711d894be7ee47596737263d82abf7bb5a8e3c68aba1d8654ea5243f151db9b73e
diff --git a/dev-ml/oasis/oasis-0.4.10.ebuild b/dev-ml/oasis/oasis-0.4.10.ebuild
new file mode 100644
index 000000000000..77c62f0572a2
--- /dev/null
+++ b/dev-ml/oasis/oasis-0.4.10.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+OASIS_BUILD_TESTS=1
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+MY_P=${P/_/\~}
+DESCRIPTION="OASIS is a tool to integrate a configure, build and install system in OCaml project"
+HOMEPAGE="http://oasis.forge.ocamlcore.org/index.php"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/1694/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=">=dev-ml/ocaml-data-notation-0.0.11:=
+ dev-ml/ocamlbuild:=[ocamlopt]
+ dev-ml/camlp4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-ml/findlib-1.3.1
+ dev-ml/ocamlify
+ dev-ml/ocamlmod
+ !<sci-chemistry/oasis-4.0-r3
+ test? (
+ >=dev-ml/ocaml-fileutils-0.4.2
+ >=dev-ml/ounit-2.0.0
+ >=dev-ml/ocaml-expect-0.0.4
+ dev-ml/pcre-ocaml
+ dev-ml/extlib
+ )"
+
+STRIP_MASK="*/bin/*"
+S="${WORKDIR}/${MY_P}"
+DOCS=( "README.md" "TODO.txt" "AUTHORS.md" "CHANGES.txt" )