summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-02-06 17:32:16 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-02-06 17:32:26 +0100
commitf7c9abd9fad7e0e9224ed7bd0106fac3b97c719e (patch)
tree4136d98a1ceda308aff25b890e0d71b7ecad15d8 /dev-ml/ocaml-cairo
parentapp-misc/ca-certificates: bump. (diff)
downloadgentoo-f7c9abd9fad7e0e9224ed7bd0106fac3b97c719e.tar.gz
gentoo-f7c9abd9fad7e0e9224ed7bd0106fac3b97c719e.tar.bz2
gentoo-f7c9abd9fad7e0e9224ed7bd0106fac3b97c719e.zip
dev-ml/ocaml-cairo: initial import; ebuild by me
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml/ocaml-cairo')
-rw-r--r--dev-ml/ocaml-cairo/Manifest1
-rw-r--r--dev-ml/ocaml-cairo/metadata.xml8
-rw-r--r--dev-ml/ocaml-cairo/ocaml-cairo-0.5.ebuild29
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-ml/ocaml-cairo/Manifest b/dev-ml/ocaml-cairo/Manifest
new file mode 100644
index 000000000000..b1f9a4719b1f
--- /dev/null
+++ b/dev-ml/ocaml-cairo/Manifest
@@ -0,0 +1 @@
+DIST ocaml-cairo-0.5.tar.gz 137433 SHA256 12b2468ebc8af481f2f01de0817410a1b880ab87d76498d8d904fe4c8e6ba994 SHA512 c946739e4d0e7ca1c7f2ffa547c138ad47265bc7f59da17242ee8a78a31b7a2ce777835dc3f4070963a7303891d2fba831171e0252a5bd908083e66515aba083 WHIRLPOOL 798dfd135f5646858b8b7583605be571375e8586a1c205f60add54343617ce3fa76ead720999d40c3350ac668d3629ee8d1bafd48a5c17e328058a5669d1324a
diff --git a/dev-ml/ocaml-cairo/metadata.xml b/dev-ml/ocaml-cairo/metadata.xml
new file mode 100644
index 000000000000..ffac4d7ebc01
--- /dev/null
+++ b/dev-ml/ocaml-cairo/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-ml/ocaml-cairo/ocaml-cairo-0.5.ebuild b/dev-ml/ocaml-cairo/ocaml-cairo-0.5.ebuild
new file mode 100644
index 000000000000..e412bd3e3d19
--- /dev/null
+++ b/dev-ml/ocaml-cairo/ocaml-cairo-0.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="OCaml Binding to Cairo"
+HOMEPAGE="https://github.com/Chris00/ocaml-cairo"
+SRC_URI="https://github.com/Chris00/ocaml-cairo/releases/download/0.5/cairo2-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="gtk"
+
+DEPEND="
+ gtk? ( dev-ml/lablgtk:= )
+ x11-libs/cairo
+"
+RDEPEND="${DEPEND}"
+DOCS=( README.md )
+S="${WORKDIR}/cairo2-${PV}/"
+
+src_configure() {
+ oasis_configure_opts="$(use_enable gtk lablgtk2)" oasis_src_configure
+}