summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-06-01 10:59:01 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-06-01 10:59:01 +0200
commit045f7d1abd1c9997907b750113a6be90971ce2fc (patch)
tree11e8b3a22fa7695ac4e2bad58acc0394336522dc /dev-ml/ocaml-conduit
parentdev-libs/apr-util: Fixed broken find command (bug #620254). (diff)
downloadgentoo-045f7d1abd1c9997907b750113a6be90971ce2fc.tar.gz
gentoo-045f7d1abd1c9997907b750113a6be90971ce2fc.tar.bz2
gentoo-045f7d1abd1c9997907b750113a6be90971ce2fc.zip
dev-ml/ocaml-conduit: bump to 0.15.4
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-ml/ocaml-conduit')
-rw-r--r--dev-ml/ocaml-conduit/Manifest1
-rw-r--r--dev-ml/ocaml-conduit/ocaml-conduit-0.15.4.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-ml/ocaml-conduit/Manifest b/dev-ml/ocaml-conduit/Manifest
index d415e3ea7967..65a97ce07c94 100644
--- a/dev-ml/ocaml-conduit/Manifest
+++ b/dev-ml/ocaml-conduit/Manifest
@@ -1 +1,2 @@
DIST ocaml-conduit-0.15.3.tar.gz 38921 SHA256 6760c9fed6b1c5360d74b4cd6fafbd78e1736c08d3024ed9ecb79b29ad3456db SHA512 0666ed22a93351dc8381de3eaafcf019336f9d62e6b7ed7c0bcd7e202ecfb54ede8ed999023a0ed712da6406cee872965b22c77982ed65897b2e0abfadd0a07c WHIRLPOOL e754553c08fe31be337b8f1aaf504a5319af66aea9f897b411a6ca4d8efd4a5c1ac9488cbe7ca091f7c87ce4171e3725f701a9f8359d04dfd6c6cca350a1a611
+DIST ocaml-conduit-0.15.4.tar.gz 38960 SHA256 5c18e1cd034b4f8e0f229426051a16100d30d07c83d7969e3331e0d7dec3b2d7 SHA512 12f61828c943cb60b2c9be080fb32c8fe5ba16d8bac46a8b788f2ea9b8b7a3a53563defbb05271d516365d18cddafe57051125391ac018328608c4f6537ec5b0 WHIRLPOOL 6d82618a68acdee4bb93b18c9a379ecad96ba8d88ebfe600465a7f57ea84b1dfd5cfd7e0f6dcde5f5c76c9395e3e528a9d457d54173a911079daab3ec1064253
diff --git a/dev-ml/ocaml-conduit/ocaml-conduit-0.15.4.ebuild b/dev-ml/ocaml-conduit/ocaml-conduit-0.15.4.ebuild
new file mode 100644
index 000000000000..06c6a5c4689b
--- /dev/null
+++ b/dev-ml/ocaml-conduit/ocaml-conduit-0.15.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib eutils
+
+DESCRIPTION="Dereference URIs into communication channels for Async or Lwt"
+HOMEPAGE="https://github.com/mirage/ocaml-conduit"
+SRC_URI="https://github.com/mirage/ocaml-conduit/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-lang/ocaml:=
+ dev-ml/sexplib:=
+ dev-ml/stringext:=
+ dev-ml/ocaml-uri:=
+ dev-ml/logs:=
+ dev-ml/ocaml-cstruct:=
+ dev-ml/ocaml-ipaddr:=
+
+ >=dev-ml/lwt-3:=
+ dev-ml/lwt_ssl:=
+ dev-ml/async:=
+ dev-ml/ocaml-dns:=
+ dev-ml/ocaml-ssl:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ dev-ml/findlib
+ dev-ml/ocamlbuild
+ dev-ml/ppx_driver
+ dev-ml/ppx_optcomp
+ dev-ml/ppx_sexp_conv
+"
+
+DOCS=( TODO.md README.md CHANGES )
+
+src_install() {
+ findlib_src_preinst
+ default
+}