summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-08-16 13:57:30 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-08-16 13:57:30 +0200
commit1f001a8b5c7ed44829fb2f0ef0f4edd6f60132c1 (patch)
tree1e28b7567a66216bb767b7b62e2a2f84b8f7c62d /dev-ml/ocaml-containers
parentdev-ml/gen: initial import; ebuild by me (diff)
downloadgentoo-1f001a8b5c7ed44829fb2f0ef0f4edd6f60132c1.tar.gz
gentoo-1f001a8b5c7ed44829fb2f0ef0f4edd6f60132c1.tar.bz2
gentoo-1f001a8b5c7ed44829fb2f0ef0f4edd6f60132c1.zip
dev-ml/ocaml-containers: initial import; ebuild by me
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ml/ocaml-containers')
-rw-r--r--dev-ml/ocaml-containers/Manifest1
-rw-r--r--dev-ml/ocaml-containers/files/notests.patch18
-rw-r--r--dev-ml/ocaml-containers/metadata.xml8
-rw-r--r--dev-ml/ocaml-containers/ocaml-containers-0.18.ebuild33
4 files changed, 60 insertions, 0 deletions
diff --git a/dev-ml/ocaml-containers/Manifest b/dev-ml/ocaml-containers/Manifest
new file mode 100644
index 000000000000..3b998aa80135
--- /dev/null
+++ b/dev-ml/ocaml-containers/Manifest
@@ -0,0 +1 @@
+DIST ocaml-containers-0.18.tar.gz 418480 SHA256 8bac90113e229a9dc55a2f54c20cf363df43c2e72ca349a5a811ad113a6d2909 SHA512 fa61039fc3bbfcd53117ae582689ffca645b42a811ebe0fc8aa5da93ba5373c2ac54896ecaddbe3eff7593b2be44f208abb625ad3354d2b089a0b811b9f77cff WHIRLPOOL 10795e812baab4525f6fdfbc101c7b14230ef87893ccf01702a6a75e373a12bf643f775f63cb27640f0dd398da541e6c185489dc27cd9fc7bd75a4a90f34baf2
diff --git a/dev-ml/ocaml-containers/files/notests.patch b/dev-ml/ocaml-containers/files/notests.patch
new file mode 100644
index 000000000000..011edc9f65e0
--- /dev/null
+++ b/dev-ml/ocaml-containers/files/notests.patch
@@ -0,0 +1,18 @@
+Index: ocaml-containers-0.18/Makefile
+===================================================================
+--- ocaml-containers-0.18.orig/Makefile
++++ ocaml-containers-0.18/Makefile
+@@ -90,12 +90,7 @@ QTEST_PREAMBLE='open CCFun;; '
+
+ qtest-gen:
+ @mkdir -p qtest
+- @if which qtest > /dev/null ; then \
+- qtest extract --preamble $(QTEST_PREAMBLE) \
+- -o qtest/run_qtest.ml \
+- $(QTESTABLE) 2> /dev/null ; \
+- else touch qtest/run_qtest.ml ; \
+- fi
++ touch qtest/run_qtest.ml
+
+ push-stable:
+ git checkout stable
diff --git a/dev-ml/ocaml-containers/metadata.xml b/dev-ml/ocaml-containers/metadata.xml
new file mode 100644
index 000000000000..ffac4d7ebc01
--- /dev/null
+++ b/dev-ml/ocaml-containers/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-ml/ocaml-containers/ocaml-containers-0.18.ebuild b/dev-ml/ocaml-containers/ocaml-containers-0.18.ebuild
new file mode 100644
index 000000000000..a2a2dba20057
--- /dev/null
+++ b/dev-ml/ocaml-containers/ocaml-containers-0.18.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+#OASIS_BUILD_TESTS=1
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="A modular standard library focused on data structures"
+HOMEPAGE="https://github.com/c-cube/ocaml-containers"
+SRC_URI="https://github.com/c-cube/ocaml-containers/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-ml/result:=
+ dev-ml/sequence:=
+"
+DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/notests.patch" )
+
+src_configure() {
+ oasis_configure_opts="
+ --enable-unix
+ --disable-bench
+ " oasis_src_configure
+}