summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-12-19 15:56:20 +0100
committerAlexis Ballier <aballier@gentoo.org>2015-12-19 16:01:21 +0100
commit2c627ae6066276bcba1ae7b678d315a66404a20d (patch)
tree5193abae892bd92d1099ece2c6d56960a212b982 /dev-ml/ocaml-cstruct/ocaml-cstruct-1.7.1.ebuild
parentdev-ml/postgresql-ocaml: bump to 3.2.2 (diff)
downloadgentoo-2c627ae6066276bcba1ae7b678d315a66404a20d.tar.gz
gentoo-2c627ae6066276bcba1ae7b678d315a66404a20d.tar.bz2
gentoo-2c627ae6066276bcba1ae7b678d315a66404a20d.zip
dev-ml/ocaml-cstruct: bump to 1.7.1
Package-Manager: portage-2.2.26 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml/ocaml-cstruct/ocaml-cstruct-1.7.1.ebuild')
-rw-r--r--dev-ml/ocaml-cstruct/ocaml-cstruct-1.7.1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-ml/ocaml-cstruct/ocaml-cstruct-1.7.1.ebuild b/dev-ml/ocaml-cstruct/ocaml-cstruct-1.7.1.ebuild
new file mode 100644
index 000000000000..647990bf3475
--- /dev/null
+++ b/dev-ml/ocaml-cstruct/ocaml-cstruct-1.7.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="Map OCaml arrays onto C-like structs"
+HOMEPAGE="https://github.com/mirage/ocaml-cstruct https://mirage.io"
+SRC_URI="https://github.com/mirage/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="async +camlp4 +lwt"
+
+RDEPEND="
+ async? ( dev-ml/async:= )
+ camlp4? ( dev-ml/camlp4:= )
+ lwt? ( dev-ml/lwt:= )
+ >=dev-lang/ocaml-4.01:=
+ dev-ml/ocplib-endian:=
+ dev-ml/sexplib:=
+ dev-ml/type-conv:=
+"
+DEPEND="
+ test? ( dev-ml/ounit )
+ ${RDEPEND}
+"
+
+src_configure() {
+ oasis_configure_opts="
+ $(use_enable lwt)
+ $(use_enable camlp4)
+ $(use_enable async)
+ --enable-unix
+ " oasis_src_configure
+}
+
+DOCS=( CHANGES README.md TODO.md )