summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-07-01 13:00:48 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-07-01 15:22:45 +0200
commit488c59ca271daeb86c84eaa6b6abcd1ea1d40afb (patch)
tree0f43af1a80991fefa6853d551694f242bcd928c2 /dev-ml/ocaml-cstruct
parentdev-ml/ocaml-cstruct: remove old (diff)
downloadgentoo-488c59ca271daeb86c84eaa6b6abcd1ea1d40afb.tar.gz
gentoo-488c59ca271daeb86c84eaa6b6abcd1ea1d40afb.tar.bz2
gentoo-488c59ca271daeb86c84eaa6b6abcd1ea1d40afb.zip
dev-ml/ocaml-cstruct: bump to 2.2.0
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ml/ocaml-cstruct')
-rw-r--r--dev-ml/ocaml-cstruct/Manifest1
-rw-r--r--dev-ml/ocaml-cstruct/ocaml-cstruct-2.2.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-ml/ocaml-cstruct/Manifest b/dev-ml/ocaml-cstruct/Manifest
index 9c06844a06ec..b012b7673d29 100644
--- a/dev-ml/ocaml-cstruct/Manifest
+++ b/dev-ml/ocaml-cstruct/Manifest
@@ -1 +1,2 @@
DIST ocaml-cstruct-2.1.0.tar.gz 251162 SHA256 fab6525753af5f726810b321a97b8a0b226bf0318a3ed594e2ed93f2f293c9a1 SHA512 129650ec17d8c96d6e68fc6a814e2b44cecc6fc69dfd5327c48d842447caf172c36112ef4fe0fa85c7391172ba72e2f2d3c119f44075cf1240a89134830ec428 WHIRLPOOL 4daf175682710cc0b102858df5b66c8cc14caf0ab35d4d8430324ed65bcaab9d951f391bdb3c39c5b6edfca4fac50300f4c394a3adbae43269a31abf04955661
+DIST ocaml-cstruct-2.2.0.tar.gz 251257 SHA256 9d605469131a8a704d123dbedff7dc7f68ccb7e28e76ddafda745017e58217e1 SHA512 4aee07f2e0c6490eef564eff194fc3a9563b1e6020b2903bed3c18b46c6698f7593ab0e6f893d3f0781510a4a2e8a6bdac379db497d469d7d34b94b2047dfed8 WHIRLPOOL 4a2dd17d739509e7afd4871f788292d1abba19fcdfa1cec4f8a6d4675e9eeef4f2de0d6256d965ed988c27255e495570f3326b9b144ea132f376e83c60b679e0
diff --git a/dev-ml/ocaml-cstruct/ocaml-cstruct-2.2.0.ebuild b/dev-ml/ocaml-cstruct/ocaml-cstruct-2.2.0.ebuild
new file mode 100644
index 000000000000..ec1f10ab6940
--- /dev/null
+++ b/dev-ml/ocaml-cstruct/ocaml-cstruct-2.2.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="Map OCaml arrays onto C-like structs"
+HOMEPAGE="https://github.com/mirage/ocaml-cstruct https://mirage.io"
+SRC_URI="https://github.com/mirage/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="async +lwt +ppx"
+
+RDEPEND="
+ async? ( dev-ml/async:= )
+ lwt? ( dev-ml/lwt:= )
+ ppx? ( dev-ml/ppx_tools:= )
+ >=dev-lang/ocaml-4.01:=
+ dev-ml/ocplib-endian:=
+ dev-ml/sexplib:=
+ dev-ml/type-conv:=
+"
+DEPEND="
+ test? ( dev-ml/ounit )
+ ${RDEPEND}
+"
+
+src_configure() {
+ oasis_configure_opts="
+ $(use_enable lwt)
+ $(use_enable async)
+ $(use_enable ppx)
+ --enable-unix
+ " oasis_src_configure
+}
+
+DOCS=( CHANGES README.md TODO.md )