summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-01-30 19:38:19 +0100
committerAlfredo Tupone <tupone@gentoo.org>2022-01-30 19:38:19 +0100
commit6b40fdbcc5cc7a9984bc095bbc45eef1985778cc (patch)
treedc82efd2bbe39262b18415f461ff544f714f0781 /dev-ml/ocaml-ctypes
parentvirtual/imagemagick-tools: Keyword 0 for ~m68k (diff)
downloadgentoo-6b40fdbcc5cc7a9984bc095bbc45eef1985778cc.tar.gz
gentoo-6b40fdbcc5cc7a9984bc095bbc45eef1985778cc.tar.bz2
gentoo-6b40fdbcc5cc7a9984bc095bbc45eef1985778cc.zip
dev-ml/ocaml-ctypes: 0.20.0 bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/ocaml-ctypes')
-rw-r--r--dev-ml/ocaml-ctypes/Manifest1
-rw-r--r--dev-ml/ocaml-ctypes/ocaml-ctypes-0.20.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-ml/ocaml-ctypes/Manifest b/dev-ml/ocaml-ctypes/Manifest
index d36f7d612cd4..fd32fb6a117d 100644
--- a/dev-ml/ocaml-ctypes/Manifest
+++ b/dev-ml/ocaml-ctypes/Manifest
@@ -1,2 +1,3 @@
DIST ocaml-ctypes-0.17.1.tar.gz 208101 BLAKE2B b9fe6632058a670c988ba9f1ae81b75aa5373de7231cef04d5e2ede61a44cbaa0324c04197a0a202847599a9bbe7dccd18fd3279f3f351493aaec4959caf3ada SHA512 1e197009f7e6b29b43944f757e987934337ebfa11bb2ff2ca8ba3ebc607e37cf1259d07a90d7faf4b91b49ee20d5c65357ad305f34ada0a8d336a3904233150e
DIST ocaml-ctypes-0.19.1.tar.gz 206762 BLAKE2B 29b4636e711b9b3ecf3de5d66b796d4d8ddf1109fd7b065666577ce9412e0ef3712f704729dac3b9467ac7ace8f501b90bfc1dc82b86dbe1668e5d13be46741f SHA512 cbf422a2c457b215815a04122d0522ed0f274c5927cecd25951472de6cc6fcd1151b67f95d6bbfeeb3b5f15a9fe9bdedb8861e77bd0de9902418962065e4dfc0
+DIST ocaml-ctypes-0.20.0.tar.gz 206559 BLAKE2B d9bf1c3f5ae7544e3950766f7eb9bac2c9dbf84130f69b2b8807e55c6a7d659c46d9ba2227d53d578e4e49283730932213eea4c7487beffe4540432b3e700c81 SHA512 605ae95b0233f1157749475526ef00ade2f97649d06a782e8fcf97b604cb86a0dcc8f27c4ac6baec11a41b9ef5becb0e5ae55e30f1ee61b30d4ae17a0d1545c2
diff --git a/dev-ml/ocaml-ctypes/ocaml-ctypes-0.20.0.ebuild b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.20.0.ebuild
new file mode 100644
index 000000000000..22dbf916bf59
--- /dev/null
+++ b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.20.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit findlib
+
+DESCRIPTION="Library for binding to C libraries using pure OCaml"
+HOMEPAGE="https://github.com/ocamllabs/ocaml-ctypes"
+SRC_URI="https://github.com/ocamllabs/ocaml-ctypes/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.02:=[ocamlopt]
+ >=dev-libs/libffi-3.3_rc0:=
+ dev-ml/bigarray-compat:=
+ dev-ml/integers:=
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ml/ounit2 dev-ml/lwt )"
+
+src_prepare() {
+ sed -e 's/oUnit/ounit2/g' -i Makefile.tests || die
+ default
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_test() {
+ emake -j1 test
+}
+
+src_install() {
+ findlib_src_install
+ dodoc CHANGES.md README.md
+}