summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Brewer <tomboy64@sina.cn>2015-11-26 01:32:51 +0100
committerMatthew Brewer <tomboy64@sina.cn>2015-11-26 14:58:16 +0100
commitceea92da4557f96584b31bb51d91a4055d1bff58 (patch)
tree1ec40cdb0471f970ef61c6784622fc514c52cbdc /dev-ml/ocaml-dns
parentnet-misc/vino: drop redundant gcrypt configure switch (diff)
downloadgentoo-ceea92da4557f96584b31bb51d91a4055d1bff58.tar.gz
gentoo-ceea92da4557f96584b31bb51d91a4055d1bff58.tar.bz2
gentoo-ceea92da4557f96584b31bb51d91a4055d1bff58.zip
dev-ml/ocaml-dns: version bump to 0.16.0
Diffstat (limited to 'dev-ml/ocaml-dns')
-rw-r--r--dev-ml/ocaml-dns/Manifest1
-rw-r--r--dev-ml/ocaml-dns/ocaml-dns-0.16.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-ml/ocaml-dns/Manifest b/dev-ml/ocaml-dns/Manifest
index 01f2a439d1b9..022296ff4141 100644
--- a/dev-ml/ocaml-dns/Manifest
+++ b/dev-ml/ocaml-dns/Manifest
@@ -1 +1,2 @@
DIST ocaml-dns-0.15.3.tar.gz 143042 SHA256 cc1361e51d1a7b6fa8d552dc06cad09288ba00e78a9ddcd5a0e49ab3d12a9619 SHA512 7176e93a263975d31a6757acf01ac5be10eb34b19a2c3a5d5e92b087a574e76db16861923162ad73833379dc5132868d0b91e1f2ed692e2bdff5667938a76db6 WHIRLPOOL 9b282ffdaf9fd834d449e33176fb9e5a231e6a7f2a1a12b0da4825a96f820b3f87a73c9e4751c19bbf80c9b8ab2f30c1730003b010bd6153b83bb9009334986d
+DIST ocaml-dns-0.16.0.tar.gz 146761 SHA256 b8b56f9979b650ae3f1a9a52385027c5a80e7f5bd25e6326d0fef480a5f0a56f SHA512 8d5f8c63074dae68d31dd1a592d3fa6b69e0963aa674110e501a575b4cb75c3a9a5ad6b1efffd118d69eff6dcf71f34b102264a127c9b336b2f04de5a90ee976 WHIRLPOOL f927983e894c65c1ed007897bd0dae2f2b45fdf215a12c50e15c4a554f6c9c9f69e5ea5defd60f71478ad527995957698b63cf48b24601f82098c55e97002e05
diff --git a/dev-ml/ocaml-dns/ocaml-dns-0.16.0.ebuild b/dev-ml/ocaml-dns/ocaml-dns-0.16.0.ebuild
new file mode 100644
index 000000000000..bf1a7813ec71
--- /dev/null
+++ b/dev-ml/ocaml-dns/ocaml-dns-0.16.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="A pure OCaml implementation of the DNS protocol"
+HOMEPAGE="https://github.com/mirage/ocaml-dns https://mirage.io"
+SRC_URI="https://github.com/mirage/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2 LGPL-2.1-with-linking-exception ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="async +lwt"
+
+RDEPEND="
+ async? ( >=dev-ml/async-112.24.00:= )
+ lwt? ( >=dev-ml/lwt-2.4.7:=
+ dev-ml/ocaml-cstruct:=[lwt(-)] )
+ >=dev-lang/ocaml-4:=
+ dev-ml/cmdliner:=
+ dev-ml/mirage-profile:=
+ >=dev-ml/ocaml-base64-2.0.0:=
+ >=dev-ml/ocaml-cstruct-1.0.1:=
+ >=dev-ml/ocaml-ipaddr-2.6.0:=
+ dev-ml/ocaml-re:=
+ >=dev-ml/ocaml-uri-1.7.0:=
+ !<dev-ml/mirage-types-1.2.0
+ !dev-ml/odns
+"
+DEPEND="
+ test? ( dev-ml/ounit
+ dev-ml/ocaml-pcap )
+ ${RDEPEND}
+"
+
+src_configure() {
+ oasis_configure_opts="
+ $(use_enable async)
+ $(use_enable lwt)
+ $(use_enable test nettests)
+ " oasis_src_configure
+}
+
+DOCS=( CHANGES README.md TODO.md )