summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-03-14 10:44:42 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-03-14 11:21:23 +0100
commit43d7758630303cbb21c3e0c6796011a494784d54 (patch)
tree6bab4045583a944fdc6f182eb0e060005894db6a /dev-ml/ocaml-gettext/ocaml-gettext-0.3.7.ebuild
parentx11-wm/marco: add mate-base/mate-desktop as runtime dependency, bug #611478 #... (diff)
downloadgentoo-43d7758630303cbb21c3e0c6796011a494784d54.tar.gz
gentoo-43d7758630303cbb21c3e0c6796011a494784d54.tar.bz2
gentoo-43d7758630303cbb21c3e0c6796011a494784d54.zip
dev-ml/ocaml-gettext: Bump to 0.3.7
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-ml/ocaml-gettext/ocaml-gettext-0.3.7.ebuild')
-rw-r--r--dev-ml/ocaml-gettext/ocaml-gettext-0.3.7.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-ml/ocaml-gettext/ocaml-gettext-0.3.7.ebuild b/dev-ml/ocaml-gettext/ocaml-gettext-0.3.7.ebuild
new file mode 100644
index 000000000000..90649dc623b9
--- /dev/null
+++ b/dev-ml/ocaml-gettext/ocaml-gettext-0.3.7.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib eutils autotools
+
+DESCRIPTION="Provides support for internationalization of OCaml program"
+HOMEPAGE="https://github.com/gildor478/ocaml-gettext"
+SRC_URI="https://github.com/gildor478/ocaml-gettext/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND=">=dev-lang/ocaml-3.12.1:=
+ >=dev-ml/ocaml-fileutils-0.4.0:=
+ >=dev-ml/camomile-0.8.3:=
+ sys-devel/gettext
+ dev-ml/camlp4:=
+ "
+DEPEND="${RDEPEND}
+ doc? ( app-text/docbook-xsl-stylesheets dev-libs/libxslt )
+ test? ( dev-ml/ounit )"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-docbook-stylesheet="${EPREFIX}/usr/share/sgml/docbook/xsl-stylesheets/" \
+ $(use_enable doc) \
+ $(use_enable test)
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ findlib_src_preinst
+ emake -j1 DESTDIR="${D}" \
+ BINDIR="${ED}/usr/bin" \
+ PODIR="${ED}/usr/share/locale/" \
+ DOCDIR="${ED}/usr/share/doc/${PF}" \
+ MANDIR="${ED}/usr/share/man" \
+ install
+ dodoc CHANGELOG README THANKS TODO
+}