summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-09-01 09:54:11 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-09-01 13:18:39 +0200
commit9249f2ff2792fec4cba2b8dea1940f66063afafc (patch)
treedfe766f9110d6f7e992d56f4fba525d77bd13903 /dev-ml/ocaml-hashcons/ocaml-hashcons-1.3.ebuild
parentros-meta/rosbridge_suite: Bump to 0.8.1. (diff)
downloadgentoo-9249f2ff2792fec4cba2b8dea1940f66063afafc.tar.gz
gentoo-9249f2ff2792fec4cba2b8dea1940f66063afafc.tar.bz2
gentoo-9249f2ff2792fec4cba2b8dea1940f66063afafc.zip
dev-ml/ocaml-hashcons: bump to 1.3
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-ml/ocaml-hashcons/ocaml-hashcons-1.3.ebuild')
-rw-r--r--dev-ml/ocaml-hashcons/ocaml-hashcons-1.3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ml/ocaml-hashcons/ocaml-hashcons-1.3.ebuild b/dev-ml/ocaml-hashcons/ocaml-hashcons-1.3.ebuild
new file mode 100644
index 000000000000..7b027961ea87
--- /dev/null
+++ b/dev-ml/ocaml-hashcons/ocaml-hashcons-1.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools findlib
+
+DESCRIPTION="OCaml hash-consing library"
+HOMEPAGE="https://github.com/backtracking/ocaml-hashcons"
+SRC_URI="https://github.com/backtracking/ocaml-hashcons/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+RDEPEND="dev-lang/ocaml:=[ocamlopt?]"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ eautoreconf
+ sed -i -e 's/$(OCAMLFIND) remove/#/' Makefile.in || die
+}
+
+src_compile() {
+ if use ocamlopt; then
+ emake opt byte
+ else
+ emake byte
+ fi
+}
+
+src_install() {
+ dodir "$(ocamlfind printconf destdir)/hashcons"
+ emake DESTDIR="-destdir ${D}/$(ocamlfind printconf destdir)/" $(usex ocamlopt install-opt install-byte)
+ dodoc README.md CHANGES
+}