summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-11-29 18:23:52 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-11-29 18:23:58 +0100
commit2d75ff9581121f32249e3df091a8814e6f01f84f (patch)
tree757103d4ce7876b5c715c76ae7baf7e54646396a /dev-ml/ocaml-ipaddr
parentdev-ml/uuidm: bump to 0.9.6 (diff)
downloadgentoo-2d75ff9581121f32249e3df091a8814e6f01f84f.tar.gz
gentoo-2d75ff9581121f32249e3df091a8814e6f01f84f.tar.bz2
gentoo-2d75ff9581121f32249e3df091a8814e6f01f84f.zip
dev-ml/ocaml-ipaddr: bump to 2.7.1
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-ml/ocaml-ipaddr')
-rw-r--r--dev-ml/ocaml-ipaddr/Manifest1
-rw-r--r--dev-ml/ocaml-ipaddr/ocaml-ipaddr-2.7.1.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-ml/ocaml-ipaddr/Manifest b/dev-ml/ocaml-ipaddr/Manifest
index f9be2aa65d3e..04901af1d9d9 100644
--- a/dev-ml/ocaml-ipaddr/Manifest
+++ b/dev-ml/ocaml-ipaddr/Manifest
@@ -1,2 +1,3 @@
DIST ocaml-ipaddr-2.6.1.tar.gz 64458 SHA256 7051013d8f58abff433187d70cd7ddd7a6b49a6fbe6cad1893f571f65b8ed3d0 SHA512 a22382b5118caf0a29322e52d40523cbf52edd21d477c2e4581a5f70441b71f948b75ff7d55a7cf6c32f0e68c430c3aff59a05d9514b29e858ff78f4c649c4c6 WHIRLPOOL 418a3bcbef9a1198962bd5d09381756520eaced7e86f8ba204810b786187cfb6e020019da331d85e11d510fa744802c66d52a450fb31a9ff8a418004ff1d4cbe
DIST ocaml-ipaddr-2.7.0.tar.gz 65470 SHA256 3031abb4a5391af8b7e307db09807ef748fc718ee23855e2f933df47892d4c23 SHA512 36ce32945e05166165ba9d2d6d10a9fb1531a50ff4e9e1a87d1bf557e767fa2938af9cbaeea7da4eefd058d687f0b36696075fd4c9ed075f5207e3c9f5488c87 WHIRLPOOL 188acfc6e110253b62f92a21a08a1519650289141b9649bed2e80b7850f9cdaa8327859933501ff0b938c2896f42ba48fac57b0b4c6b3ea59b6f4368eac0bd28
+DIST ocaml-ipaddr-2.7.1.tar.gz 23652 SHA256 0d1d5fe983ff02ed09a0f03e5f1048c575d621599b42b5685d56f4da61186888 SHA512 9f640f10614666f3a7cc578e934b0424c1d6fdcdd2dc5620f4a8b4fa7799a07fdd7c4bbe4e91c4899d45612ce8d2d4cafc8bcd19e51253c6da5d12c504820903 WHIRLPOOL 5be5846d98fbec95c5d3ba47c3b59bbdd3c44e41d04270d0b0ca2331eb7e6aac3d79c4833bf8dd20edb2d0c9f03b3bc72c53f12e0d27fb9980bcf73dea2c17f4
diff --git a/dev-ml/ocaml-ipaddr/ocaml-ipaddr-2.7.1.ebuild b/dev-ml/ocaml-ipaddr/ocaml-ipaddr-2.7.1.ebuild
new file mode 100644
index 000000000000..ab99fa521de0
--- /dev/null
+++ b/dev-ml/ocaml-ipaddr/ocaml-ipaddr-2.7.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="OCaml library for manipulation of IP (and MAC) address representations"
+HOMEPAGE="https://github.com/mirage/ocaml-ipaddr"
+SRC_URI="https://github.com/mirage/ocaml-ipaddr/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt test"
+
+RDEPEND="dev-ml/sexplib:=
+ dev-ml/ppx_sexp_conv:=
+ dev-lang/ocaml:=[ocamlopt?]
+"
+DEPEND="${RDEPEND}
+ dev-ml/ocamlbuild
+ dev-ml/topkg
+ dev-ml/findlib
+ test? ( dev-ml/ounit )
+"
+
+src_compile() {
+ ocaml pkg/pkg.ml build \
+ --tests $(usex test "true" "false") || die
+}
+
+src_test() {
+ ocaml pkg/pkg.ml test || die
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ipaddr.install || die
+ dodoc CHANGES.md README.md
+}