summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-08-04 20:57:52 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-08-06 08:45:18 +0200
commit413f801bb5538c134f724e6d265356f4f632e0bc (patch)
tree96166de2328c723540ce4879170c27b5d2eba31a /dev-ml/ocaml-sqlite3/ocaml-sqlite3-4.2.0.ebuild
parentdev-ml/postgresql-ocaml: bump to 4.1.0 (diff)
downloadgentoo-413f801bb5538c134f724e6d265356f4f632e0bc.tar.gz
gentoo-413f801bb5538c134f724e6d265356f4f632e0bc.tar.bz2
gentoo-413f801bb5538c134f724e6d265356f4f632e0bc.zip
dev-ml/ocaml-sqlite3: bump to 4.2.0
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-ml/ocaml-sqlite3/ocaml-sqlite3-4.2.0.ebuild')
-rw-r--r--dev-ml/ocaml-sqlite3/ocaml-sqlite3-4.2.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ml/ocaml-sqlite3/ocaml-sqlite3-4.2.0.ebuild b/dev-ml/ocaml-sqlite3/ocaml-sqlite3-4.2.0.ebuild
new file mode 100644
index 000000000000..6b298cba0bfb
--- /dev/null
+++ b/dev-ml/ocaml-sqlite3/ocaml-sqlite3-4.2.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit opam
+
+MY_PN="sqlite3"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A package for ocaml that provides access to SQLite databases"
+HOMEPAGE="http://mmottl.github.io/sqlite3-ocaml/"
+SRC_URI="https://github.com/mmottl/sqlite3-ocaml/releases/download/${PV}/${MY_P}.tbz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=dev-db/sqlite-3.3.3"
+DEPEND="${RDEPEND}
+ dev-ml/jbuilder
+ >=dev-ml/findlib-1.3.2"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ jbuilder build @install || die
+}
+
+src_install() {
+ opam_src_install "${MY_PN}"
+}