summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-10-14 14:10:07 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-10-14 14:10:07 +0200
commitc20e4f44938c92ade1d1d25499686789118fcb0a (patch)
treea0d95bed20aa3e274d9ab2f8997b3810a8d46b45 /dev-ml/ocaml-ssl/ocaml-ssl-0.5.5.ebuild
parentdev-python/simplekv: bump to 0.11.3 (diff)
downloadgentoo-c20e4f44938c92ade1d1d25499686789118fcb0a.tar.gz
gentoo-c20e4f44938c92ade1d1d25499686789118fcb0a.tar.bz2
gentoo-c20e4f44938c92ade1d1d25499686789118fcb0a.zip
dev-ml/ocaml-ssl: bump to 0.5.5
Package-Manager: Portage-2.3.11, Repoman-2.3.3
Diffstat (limited to 'dev-ml/ocaml-ssl/ocaml-ssl-0.5.5.ebuild')
-rw-r--r--dev-ml/ocaml-ssl/ocaml-ssl-0.5.5.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ml/ocaml-ssl/ocaml-ssl-0.5.5.ebuild b/dev-ml/ocaml-ssl/ocaml-ssl-0.5.5.ebuild
new file mode 100644
index 000000000000..93d736e30add
--- /dev/null
+++ b/dev-ml/ocaml-ssl/ocaml-ssl-0.5.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib eutils
+
+IUSE="doc"
+
+DESCRIPTION="OCaml bindings for OpenSSL"
+SRC_URI="https://github.com/savonet/ocaml-ssl/releases/download/${PV}/${P}.tar.gz"
+HOMEPAGE="https://github.com/savonet/ocaml-ssl"
+
+DEPEND="dev-libs/openssl:0=
+ >=dev-lang/ocaml-3.10:="
+RDEPEND="${DEPEND}"
+
+SLOT="0/${PV}"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~x86-fbsd"
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ findlib_src_preinst
+ emake install
+
+ if use doc; then
+ dohtml -r doc/html/*
+ fi
+ dodoc CHANGES README.md
+}