summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-03-09 10:08:21 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-03-09 10:08:21 +0100
commit2f59c7835fe3816b58fe2a6120c1f62cc93c16cd (patch)
treebd29432f8a3832fc21f9a926ee1d4747803b0f94 /dev-ml/ocamlbuild/ocamlbuild-0.11.0.ebuild
parentdev-ml/jsonm: Bump to 1.0.1 (diff)
downloadgentoo-2f59c7835fe3816b58fe2a6120c1f62cc93c16cd.tar.gz
gentoo-2f59c7835fe3816b58fe2a6120c1f62cc93c16cd.tar.bz2
gentoo-2f59c7835fe3816b58fe2a6120c1f62cc93c16cd.zip
dev-ml/ocamlbuild: Bump to 0.11.0
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-ml/ocamlbuild/ocamlbuild-0.11.0.ebuild')
-rw-r--r--dev-ml/ocamlbuild/ocamlbuild-0.11.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ml/ocamlbuild/ocamlbuild-0.11.0.ebuild b/dev-ml/ocamlbuild/ocamlbuild-0.11.0.ebuild
new file mode 100644
index 000000000000..f6a3478c9228
--- /dev/null
+++ b/dev-ml/ocamlbuild/ocamlbuild-0.11.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+DESCRIPTION="Generic build tool with built-in rules for building OCaml library and programs"
+HOMEPAGE="https://github.com/ocaml/ocamlbuild"
+SRC_URI="https://github.com/ocaml/ocamlbuild/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="+ocamlopt"
+
+DEPEND=">=dev-lang/ocaml-4.02.3-r1:=[ocamlopt?]"
+RDEPEND="${DEPEND}
+ !<dev-ml/findlib-1.6.1-r1
+"
+
+src_configure() {
+ emake -f configure.make Makefile.config \
+ PREFIX="${EPREFIX}/usr" \
+ BINDIR="${EPREFIX}/usr/bin" \
+ LIBDIR="$(ocamlc -where)" \
+ OCAML_NATIVE=$(usex ocamlopt true false) \
+ OCAML_NATIVE_TOOLS=$(usex ocamlopt true false) \
+ NATDYNLINK=$(usex ocamlopt true false)
+}
+
+src_install() {
+ emake CHECK_IF_PREINSTALLED=false DESTDIR="${D}" install
+ dodoc Changes
+}